Marvel in Red state while indexing


#1

Hi,

I'm new to Kibana and Marvel.
I have a problem where Kibana is always Red when i'm bulk indexing documents (i'm using the Bulk JAVA API)
After the indexing, it goes back alive and shows some stats, but no graph history. The cluster is green though when i curl _health the cluster via the REST API.

Any idea how to fix this ? i've already tried to delete the .kibana index and restart my elastic cluster.

Thx.


(Lee Drengenberg) #2

What version of Elasticsearch and Kibana are you using?

Can you paste some logs here that show the state going red? Or a screen shot?

Thanks,
Lee


(Mark Walkom) #3

Use the _cat/indices API to check what is not allocated.


(Christian Dahlqvist) #4

Are you indexing into existing indices or are indices automatically created as a result of your indexing? How many indices do you have? What is the size of the cluster? Which version of Elasticsearch are you on?


#5

Thanks for your replies,

I'm using Elastic 2.2 and Kibana 4.4 and i'm pulling the latest Marvel plugin (i'm using Docker)
The cluster is Green (when i check the health by /_cluster/health) but form time to time (it is not a constant thing) kibana is red.
I am indexing to existing indices (created manually before bulk indexing) i have 12 indices and the cluster is a basically a three nodes setup with 30 GB of RAM each and 4TB of HDD (NFS)
What i noticed is that when the cluster is idle or does not do too much of indexing, Marvel becomes live and shows some activity (no history though on indexing/activity graphs) but when i'm bulk indexing Kibana goes Red most of the time and Marvel neither Sense are available.
I've tried to delete the .marvel* indices

Thank you for your time.


(Mark Walkom) #6

Yuck, we don't recommend this because it's too slow.


#7

Yeah i know :confused: but this is not much of a personal choice... Local SSD is the recommendation.


(Christian Dahlqvist) #8

Make sure you have followed the following guidelines, especially with respect to index.merge.scheduler.max_thread_count as you have slow disks.


#9

Thanks for your replies.
I added the line index.merge.scheduler.max_thread_count: 1 to my yml files
I'll try now to do bulk import and see how it goes.


(system) #10