Marvel shows empty dashboard


(Ron Sher) #1

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4d0f4f2e-f824-408f-bff1-d4d79aec470c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #2

Hi Ron,

I assume you waited a bit for the data to be collected and indexed?

Please post a screenshot + url of what you see and we'd look further.

Cheers,
Boaz

On Thursday, January 30, 2014 1:22:03 PM UTC+1, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0ef3a4ce-c191-474b-8ae1-fb021b65255e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(DH) #3

Hello,
I had the same problem.
For me, It was because I didn't pay attention enough.
What is your version of ES? You need to have a 90.9 or higher. On my
former 0.90.5, the pugin was detected but showed nothing.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d852c6a9-2bd4-428f-a36a-7f3458537e81%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #4

We have 0.90.10

On Thu, Jan 30, 2014 at 2:41 PM, DH ciddp195@gmail.com wrote:

Hello,
I had the same problem.
For me, It was because I didn't pay attention enough.
What is your version of ES? You need to have a 90.9 or higher. On my
former 0.90.5, the pugin was detected but showed nothing.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d852c6a9-2bd4-428f-a36a-7f3458537e81%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJphzG4%3D4%2B8NYedR6%2BLCXwuYPioyLKMXsGfLw5majuG%2BqA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brad Jordan-2) #5

I also have the same issue. I'm running elasticsearch-0.90.7. I installed
the plugin, bounced the cluster and Marvel is just blank. Is there a config
I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #6

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,

Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climberbrad@gmail.com
wrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I installed
the plugin, bounced the cluster and Marvel is just blank. Is there a config
I'm missing?
-Brad
On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1391103815201.ae900fa6%40Nodemailer.
For more options, visit https://groups.google.com/groups/opt_out.


(Brad Jordan-2) #7

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan <climb...@gmail.com<javascript:>

wrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I installed
the plugin, bounced the cluster and Marvel is just blank. Is there a config
I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6466dbb6-084f-4fb5-bffc-14beeaf3cff5%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brad Jordan-2) #8

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.com wrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02f05ff6-2523-4eb1-a1e0-9bd9a65f8673%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brad Jordan-2) #9

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.com wrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b7a84d31-97b8-4eb7-809a-59f494240ed3%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #10

Can you check if you have indices named .marvel-* ?

The easiest way to check would be:

curl -XGET "http://localhost:10000/.marvel*/_stats?clear&store"

You should get an entry for every index.

On Thu, Jan 30, 2014 at 8:24 PM, Brad Jordan climberbrad@gmail.com wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b7a84d31-97b8-4eb7-809a-59f494240ed3%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKzwz0o0dp4y35QoV4KUS91oh8oit1rQFWb_rX%3Do4TmYCR6tPQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #11

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there would
not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES services
on every node? Otherwise you're still stuck on the previous version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brad Jordan-2) #12

I actually READ the install instructions this time! You have to install it
on all your nodes AND bounce the cluster. After that it worked like a
charm!

Thanks,
Brad

On Thursday, January 30, 2014 12:24:11 PM UTC-7, Brad Jordan wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e93b74be-7bfc-4893-8531-40cb3c8002e5%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #13

Hi Tony,

Marvel starts collecting stats 5 seconds after the node starts. If that's
not happening for you, something else is wrong (an let's please open
another thread on it, this one is already all over the place :wink: ).

As to ES version - with the exception of a rolling upgrade you are highly
recommended to keep the versions of all nodes the same. This goes for both
ES versions and the Java version you use. This is necessary to guaranty the
correct behavior of the cluster.

Cheers,
Boaz

On Thursday, January 30, 2014 11:47:36 PM UTC+1, Tony Su wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there would
not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d55bddb3-f7d4-4247-ab26-6d7007486eac%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #14

I don't see any indices of marve:

ron@ron-VirtualBox:~$ curl -XGET "http://hades3:10000/.marvel*/_stats?
clear&store"
curl: (7) couldn't connect to host
ron@ron-VirtualBox:~$ curl -XGET "http://hades3:9200/.marvel*/_stats?
clear&store"
{"error":"IndexMissingException[[.marvel*] missing]","status":404}

On Fri, Jan 31, 2014 at 10:31 AM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Tony,

Marvel starts collecting stats 5 seconds after the node starts. If that's
not happening for you, something else is wrong (an let's please open
another thread on it, this one is already all over the place :wink: ).

As to ES version - with the exception of a rolling upgrade you are highly
recommended to keep the versions of all nodes the same. This goes for both
ES versions and the Java version you use. This is necessary to guaranty the
correct behavior of the cluster.

Cheers,
Boaz

On Thursday, January 30, 2014 11:47:36 PM UTC+1, Tony Su wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there would
not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because
no indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-
89fe-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d55bddb3-f7d4-4247-ab26-6d7007486eac%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJpBsioPKLDXUcfiu_o6yHVa0_4cWVTU65g5WB6gXrD7PQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #15

Tony,
What do you mean by ?

Indeed I've added marvel to an already running cluster and no data is shown
in the dashboard and I don't see any marvel index

Ron

On Fri, Jan 31, 2014 at 12:47 AM, Tony Su tonysu999@gmail.com wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there would
not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2zFd2OD-w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #16

Hi Ron,

It looks like no data is sent. What version of ES are you running? Did you restart tES after installing the plugin?

Regards,

Boaz

On Sun, Feb 2, 2014 at 8:27 AM, Ron Sher ron.sher@gmail.com wrote:

Tony,
What do you mean by ?
Indeed I've added marvel to an already running cluster and no data is shown
in the dashboard and I don't see any marvel index
Ron
On Fri, Jan 31, 2014 at 12:47 AM, Tony Su tonysu999@gmail.com wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there would
not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because no
indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel dashboard...

I have about 30 indexes which all have data starting on about 1/20/2014
going back to 5/01/2013. Bigdesk and the Head plugin have no problems
seeing that nodes, shards, indexes. Is there an additional step I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/4dcf998b-89fe-4f07-bb2d-a036cd567c66%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2zFd2OD-w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1391327120065.1c3e15a9%40Nodemailer.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #17

again, using 0.90.10.
This is what I did:
bin/plugin -i elasticsearch/marvel/latest
/etc/init.d/elasticsearch restart

Did the same on a different cluster - still doesn't work.

On Sun, Feb 2, 2014 at 9:45 AM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ron,

It looks like no data is sent. What version of ES are you running? Did you
restart tES after installing the plugin?

Regards,
Boaz

On Sun, Feb 2, 2014 at 8:27 AM, Ron Sher ron.sher@gmail.com wrote:

Tony,
What do you mean by ?

Indeed I've added marvel to an already running cluster and no data is
shown in the dashboard and I don't see any marvel index

Ron

On Fri, Jan 31, 2014 at 12:47 AM, Tony Su tonysu999@gmail.com wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same version.
So, for example if Marvel is pointing to an odd-ball ES node, there
would not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because
no indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel
dashboard...

I have about 30 indexes which all have data starting on about
1/20/2014 going back to 5/01/2013. Bigdesk and the Head plugin have no
problems seeing that nodes, shards, indexes. Is there an additional step
I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-
89fe-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

   --

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2zFd2OD-w%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1391327120065.1c3e15a9%40Nodemailer
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJrc%2BcohunMv-8nmRaoAmfzfnw%3DfNZkPmzbKRKbWOz0kvw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #18

OK, interesting.

Can you check the logs on one of the nodes to if there are any errors? also
please double check that when the node started it logged a line similar to
the following (containing marvel in the list after loaded):

[2014-02-02 09:03:48,043][INFO ][plugins ] [Stonewall]loaded
[marvel], sites [marvel]

start a node (one is enough)

On Sunday, February 2, 2014 8:50:47 AM UTC+1, Ron Sher wrote:

again, using 0.90.10.
This is what I did:
bin/plugin -i elasticsearch/marvel/latest
/etc/init.d/elasticsearch restart

Did the same on a different cluster - still doesn't work.

On Sun, Feb 2, 2014 at 9:45 AM, Boaz Leskes <b.le...@gmail.com<javascript:>

wrote:

Hi Ron,

It looks like no data is sent. What version of ES are you running? Did
you restart tES after installing the plugin?

Regards,
Boaz

On Sun, Feb 2, 2014 at 8:27 AM, Ron Sher <ron....@gmail.com <javascript:>

wrote:

Tony,
What do you mean by ?

Indeed I've added marvel to an already running cluster and no data is
shown in the dashboard and I don't see any marvel index

Ron

On Fri, Jan 31, 2014 at 12:47 AM, Tony Su <tony...@gmail.com<javascript:>

wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel to
start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same
version.
So, for example if Marvel is pointing to an odd-ball ES node, there
would not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results because
no indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel
dashboard...

I have about 30 indexes which all have data starting on about
1/20/2014 going back to 5/01/2013. Bigdesk and the Head plugin have no
problems seeing that nodes, shards, indexes. Is there an additional step
I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest followed
by a restart) by then the plugin shows an empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email
to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-
89fe-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

   -- 

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2zFd2OD-w%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1391327120065.1c3e15a9%40Nodemailer
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53e585f5-b8f8-4213-9d78-3c964971ce5f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #19

This is what I see in the log after the restart:
STATUS | wrapper | 2014/02/02 11:26:54 | Copyright (C) 1999-2011 Tanuki
Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2014/02/02 11:26:54 |
http://wrapper.tanukisoftware.com
STATUS | wrapper | 2014/02/02 11:26:54 |
WARN | wrapper | 2014/02/02 11:26:54 | Encountered an invalid numerical
value for configuration property wrapper.java.initmemory=%ES_HEAP_SIZE%.
Resolving to 0.
WARN | wrapper | 2014/02/02 11:26:54 | Encountered an invalid numerical
value for configuration property wrapper.java.maxmemory=%ES_HEAP_SIZE%.
Resolving to 0.
STATUS | wrapper | 2014/02/02 11:26:54 | Launching a JVM...
INFO | jvm 1 | 2014/02/02 11:26:55 | WrapperManager: Initializing...
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN No appenders could be
found for logger (node).
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN Please initialize the
log4j system properly.
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN See
http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

On Sun, Feb 2, 2014 at 10:05 AM, Boaz Leskes b.leskes@gmail.com wrote:

OK, interesting.

Can you check the logs on one of the nodes to if there are any errors?
also please double check that when the node started it logged a line
similar to the following (containing marvel in the list after loaded):

[2014-02-02 09:03:48,043][INFO ][plugins ] [Stonewall]loaded
[marvel], sites [marvel]

start a node (one is enough)

On Sunday, February 2, 2014 8:50:47 AM UTC+1, Ron Sher wrote:

again, using 0.90.10.
This is what I did:
bin/plugin -i elasticsearch/marvel/latest
/etc/init.d/elasticsearch restart

Did the same on a different cluster - still doesn't work.

On Sun, Feb 2, 2014 at 9:45 AM, Boaz Leskes b.le...@gmail.com wrote:

Hi Ron,

It looks like no data is sent. What version of ES are you running? Did
you restart tES after installing the plugin?

Regards,
Boaz

On Sun, Feb 2, 2014 at 8:27 AM, Ron Sher ron....@gmail.com wrote:

Tony,
What do you mean by ?

Indeed I've added marvel to an already running cluster and no data is
shown in the dashboard and I don't see any marvel index

Ron

On Fri, Jan 31, 2014 at 12:47 AM, Tony Su tony...@gmail.com wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel
to start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place, I
don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same
version.
So, for example if Marvel is pointing to an odd-ball ES node, there
would not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results
because no indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel
dashboard...

I have about 30 indexes which all have data starting on about
1/20/2014 going back to 5/01/2013. Bigdesk and the Head plugin have no
problems seeing that nodes, shards, indexes. Is there an additional step
I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/latest
followed by a restart) by then the plugin shows an empty
dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic
in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/
unsubscribe.
To unsubscribe from this group and all its topics, send an email
to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89f
e-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

   --

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2
zFd2OD-w%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/1391327120065.1c3e15a9%40Nodemailer.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e585f5-b8f8-4213-9d78-3c964971ce5f%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJrd7esT1s99gGwhPcyYg6uYbSbVvQ28gOgmo4_91Z6OmQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ron Sher) #20

I've noticed that I didn't have a logging.yml (was called logging.xml
instead).
Changed that and then I see:

[2014-02-02 15:42:19,824][ERROR][marvel.agent.exporter ] error sending
data
java.io.FileNotFoundException: http://localhost:9200/_bulk
atsun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1623)
at org.elasticsearch.marvel.agent.exporter.ESExporter.
sendCloseExportingConnection(ESExporter.java:232)
at org.elasticsearch.marvel.agent.exporter.ESExporter.exportXContent
(ESExporter.java:252)
at org.elasticsearch.marvel.agent.exporter.ESExporter.
exportClusterStats(ESExporter.java:172)
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.
exportClusterStats(AgentService.java:214)
at org.elasticsearch.marvel.agent.AgentService$ExportingWorker.run(
AgentService.java:180)
at java.lang.Thread.run(Thread.java:724)

What now?

On Sun, Feb 2, 2014 at 11:29 AM, Ron Sher ron.sher@gmail.com wrote:

This is what I see in the log after the restart:
STATUS | wrapper | 2014/02/02 11:26:54 | Copyright (C) 1999-2011 Tanuki
Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2014/02/02 11:26:54 |
http://wrapper.tanukisoftware.com
STATUS | wrapper | 2014/02/02 11:26:54 |
WARN | wrapper | 2014/02/02 11:26:54 | Encountered an invalid numerical
value for configuration property wrapper.java.initmemory=%ES_HEAP_SIZE%.
Resolving to 0.
WARN | wrapper | 2014/02/02 11:26:54 | Encountered an invalid numerical
value for configuration property wrapper.java.maxmemory=%ES_HEAP_SIZE%.
Resolving to 0.
STATUS | wrapper | 2014/02/02 11:26:54 | Launching a JVM...
INFO | jvm 1 | 2014/02/02 11:26:55 | WrapperManager: Initializing...
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN No appenders could
be found for logger (node).
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN Please initialize
the log4j system properly.
INFO | jvm 1 | 2014/02/02 11:27:01 | log4j:WARN See
http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

On Sun, Feb 2, 2014 at 10:05 AM, Boaz Leskes b.leskes@gmail.com wrote:

OK, interesting.

Can you check the logs on one of the nodes to if there are any errors?
also please double check that when the node started it logged a line
similar to the following (containing marvel in the list after loaded):

[2014-02-02 09:03:48,043][INFO ][plugins ] [Stonewall]loaded
[marvel], sites [marvel]

start a node (one is enough)

On Sunday, February 2, 2014 8:50:47 AM UTC+1, Ron Sher wrote:

again, using 0.90.10.
This is what I did:
bin/plugin -i elasticsearch/marvel/latest
/etc/init.d/elasticsearch restart

Did the same on a different cluster - still doesn't work.

On Sun, Feb 2, 2014 at 9:45 AM, Boaz Leskes b.le...@gmail.com wrote:

Hi Ron,

It looks like no data is sent. What version of ES are you running? Did
you restart tES after installing the plugin?

Regards,
Boaz

On Sun, Feb 2, 2014 at 8:27 AM, Ron Sher ron....@gmail.com wrote:

Tony,
What do you mean by ?

Indeed I've added marvel to an already running cluster and no data
is shown in the dashboard and I don't see any marvel index

Ron

On Fri, Jan 31, 2014 at 12:47 AM, Tony Su tony...@gmail.com wrote:

Just a FYI
I just installed Marvel and I noticed you need for Marvel
to start collecting and displaying data, even about itself.
If your machines are all previously setup and data already in place,
I don't know if you'd read anything.
Other thing I noticed is that ES nodes have to be the same
version.
So, for example if Marvel is pointing to an odd-ball ES node, there
would not be any activity with any other ES node so would be blank.

And, I assume that after changing ES versions you restarted the ES
services on every node? Otherwise you're still stuck on the previous
version.

HTH,
Tony

On Thursday, January 30, 2014 11:24:11 AM UTC-8, Brad Jordan wrote:

I keep getting this alert: No results There were no results
because no indices were found that match your selected time span.

-Brad

On Thursday, January 30, 2014 12:23:04 PM UTC-7, Brad Jordan wrote:

Upgraded my cluster to 0.9.10 and still get a blank Marvel
dashboard...

I have about 30 indexes which all have data starting on about
1/20/2014 going back to 5/01/2013. Bigdesk and the Head plugin have no
problems seeing that nodes, shards, indexes. Is there an additional step
I'm missing?

-Brad

On Thursday, January 30, 2014 10:48:04 AM UTC-7, Brad Jordan wrote:

Thanks!

On Thursday, January 30, 2014 10:43:35 AM UTC-7, Boaz Leskes wrote:

Hi brad,

You should upgrade to 0.90.10. 0.90.7 is not supported by marvel.

Cheers,
Boaz

On Thu, Jan 30, 2014 at 6:39 PM, Brad Jordan climb...@gmail.comwrote:

I also have the same issue. I'm running elasticsearch-0.90.7. I
installed the plugin, bounced the cluster and Marvel is just blank. Is
there a config I'm missing?

-Brad

On Thursday, January 30, 2014 5:22:03 AM UTC-7, Ron Sher wrote:

Hey,

Just tried installing the plugin.
Installation was easy (bin/plugin -i elasticsearch/marvel/
latest followed by a restart) by then the plugin shows an
empty dashboard.

Am I missing something?\

Thanks,
Ron

--
You received this message because you are subscribed to a topic
in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/
unsubscribe.
To unsubscribe from this group and all its topics, send an email
to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4dcf998b-89f
e-4f07-bb2d-a036cd567c66%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out
.

   --

You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/43083c5a-bc16-4f01-8450-15402e82d798%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/CAKHuyJr7%3Deh-s85HrwTjmKJ7wTcezU4aiSQG6P8vC2
zFd2OD-w%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/1391327120065.1c3e15a9%40Nodemailer.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/UPBMKvxwwM8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e585f5-b8f8-4213-9d78-3c964971ce5f%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKHuyJozm1Z690ocycTGFzNeJa9UByHg%3DnGP_-z2c-m7g2Ef-g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.