Max size for markdown widget?


(Chris) #1

Whenever I add a few too many links to a markdown widget I get the following fatal error:

10 $digest() iterations reached. Aborting!

Is this expected behavior?


(Joe Fleming) #2

No it's not, and it's certainly not something that should be caused by the Markdown widget - there's nothing to process there once it's registered.

Can you provide any more information? Such as your version of Kibana, the OS, browser and versions, and if it's not too sensitive, maybe even screenshots of where you are using the widget when it's working.


(Chris) #3

Kibana version is 4.4.0.
OS is Windows 7.
Browser is IE 11 I believe, I'll verify tomorrow.

The error occurs when I click the arrow to apply the changes.

I'm doing something like this in the Markdown widget:

### Quick Reference

* [Japan][1]
* [China][2]
* [Germany][3]
* [France][4]
* [Italy][5]
* [Brazil][6]

[1]: http://localhost:5601/app/kibana#/visualize/create?type=histogram&indexPattern=country*&_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:japan),query:(match:(name:(query:japan,type:phrase))))),linked:!f,query:(query_string:(analyze_wildcard:!t,query:'*')),uiState:(),vis:(aggs:!((id:'1',params:(field:gdp),schema:metric,type:sum),(id:'2',params:(field:name,order:desc,orderBy:'1',size:5),schema:segment,type:terms)),listeners:(),params:(addLegend:!t,addTimeMarker:!f,addTooltip:!t,defaultYExtents:!f,mode:stacked,scale:linear,setYExtents:!f,shareYAxis:!t,times:!(),yAxis:()),title:'New%20Visualization',type:histogram))

[2]: http://localhost:5601/app/kibana#/dashboard/test-dash?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:china),query:(match:(name:(query:china,type:phrase))))),options:(darkTheme:!f),panels:!((col:1,id:Test-Markup,panelIndex:1,row:1,size_x:3,size_y:6,type:visualization),(col:4,id:bar,panelIndex:2,row:1,size_x:9,size_y:6,type:visualization)),query:(query_string:(analyze_wildcard:!t,query:'*')),title:'test%20dash',uiState:(P-2:(vis:(legendOpen:!f))))

[3]: http://localhost:5601/app/kibana#/visualize/edit/bar?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:germany),query:(match:(name:(query:germany,type:phrase))))),linked:!f,query:(query_string:(analyze_wildcard:!t,query:'*')),uiState:(vis:(legendOpen:!f)),vis:(aggs:!((id:'1',params:(field:gdp),schema:metric,type:sum),(id:'2',params:(field:name,order:desc,orderBy:'1',size:50),schema:segment,type:terms)),listeners:(),params:(addLegend:!t,addTimeMarker:!f,addTooltip:!t,defaultYExtents:!f,mode:stacked,scale:linear,setYExtents:!f,shareYAxis:!t,times:!(),yAxis:()),title:bar,type:histogram))

[4]: http://localhost:5601/app/kibana#/dashboard/test-dash?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:france),query:(match:(name:(query:france,type:phrase))))),options:(darkTheme:!f),panels:!((col:1,id:Test-Markup,panelIndex:1,row:1,size_x:3,size_y:6,type:visualization),(col:4,id:bar,panelIndex:2,row:1,size_x:9,size_y:6,type:visualization)),query:(query_string:(analyze_wildcard:!t,query:'*')),title:'test%20dash',uiState:(P-2:(vis:(legendOpen:!f))))

[5]: http://localhost:5601/app/kibana#/dashboard/test-dash?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:italy),query:(match:(name:(query:italy,type:phrase))))),options:(darkTheme:!f),panels:!((col:1,id:Test-Markup,panelIndex:1,row:1,size_x:3,size_y:6,type:visualization),(col:4,id:bar,panelIndex:2,row:1,size_x:9,size_y:6,type:visualization)),query:(query_string:(analyze_wildcard:!t,query:'*')),title:'test%20dash',uiState:(P-2:(vis:(legendOpen:!f))))

[6]: http://localhost:5601/app/kibana#/dashboard/test-dash?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))&_a=(filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'country*',key:name,negate:!f,value:brazil),query:(match:(name:(query:brazil,type:phrase))))),options:(darkTheme:!f),panels:!((col:1,id:Test-Markup,panelIndex:1,row:1,size_x:3,size_y:6,type:visualization),(col:4,id:bar,panelIndex:2,row:1,size_x:9,size_y:6,type:visualization)),query:(query_string:(analyze_wildcard:!t,query:'*')),title:'test%20dash',uiState:(P-2:(vis:(legendOpen:!f))))

(Chris) #4

BTW, if I split the long list of links into three markdown widgets, it works fine. When I combine them back into one markdown widget, it fails when applying the change.


(Chris) #5

I verified that Kibana is version 4.4.0, OS is Windows 7, browser is IE 11.


(Joe Fleming) #6

Thanks. I think it's almost certainly related to https://github.com/elastic/kibana/issues/5968, but I believe all the reports over there are related to the Dashboard. Just to confirm, you're seeing this behavior in Visualize as you're creating the widget, right?

I have a feeling this isn't specifically a problem with the markdown widget, but we're still unable to produce that error internally, so we're having a heck of a time tracking it down...


(system) #7