Metricbeat and kibana synchronisation!

I'am new in ELK tools ! i'am starting to minitor my own server with @ !
my elasticsearch @
my kibana @
i' already installed metricbeat to collect metrics from my system and i followed this guide step by step
now i didn't have any error even elasticsearch and kibana status are working(active)
the problem that i can't visualise data on kibana dashboard !

What's the console output of Metricbeat if you run it with -e -d "*". Does the data actually reaches Elasticsearch? You can see it in the discover view in Kibana

i couldn't find the problem

Well, it's very clear that the line 5 of your YAML config file has something wrong :smiley:

I could'nt find the error

no solution for my problem !????

Please, if you want help, can you attach a YAML and not an image of your YAML? Also, attach any other module config you may have in YAML

i solved the problem but in kibana display ican't see all the metrics :woozy_face: :woozy_face:

even after uncommenting all system modules

Check if the data is visible in discover, please

1 Like

Can you detail which version of the stack you are using? It seems some issue with Kibana. I'd try to edit the visualization that's not working as expected to see if it points you at the error.

Also try to update Kibana to the latest version to see if it solves the problem

i have stack V7.5.2

i think it's the last version !

As i can see your logs, the problem is within mysql.yml

Error loading config from file '/etc/metricbeath/modules.d/mysql.yml', error invalid config: yaml: line 5: did not find expected key

Can you post it?

First of all try to disable mysql module: ${metricbeat_home}/metricbeat modules disable mysql
And after that start metricbeat.

in my first snapshot i couldn't display anything but i told you that i solved it i dit it by disabling mysql.yml
now i can display only metrics sited in snapshot !

Can you please paste your metricbeat.yml as formated text?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.