Metricbeat: CPU percentages and normalized_percentages

Hello all,

I have installed Elasticsearch, Kibana and Metricbeat (all 6.0). Everything looks great instead of CPU percentage: it shows with paying in attention cores, I guess, is I see something like 986% on Metricbeat Overview dashboard in the table "TOP hosts (CPU)". I already tried to set cpu.metrics: ["normalized_percentages"], but no changes so far.
Could anyone help?

When you enable normalized_percentages different named fields are sent by Metricbeat. See the exported fields documentation for the system.cpu metricset. For example, the total CPU can be sent in these two fields depending on how you have it configured.


If you want the dashboard to be based on the normalized percentages then you need to enabled this data in the Metricbeat config as you did, and you need to edit the dashboard to use the norm.pct value rather than the .pct field.

Thank you, I just came to the conclusion I need to change the dashboard.

This topic was automatically closed after 21 days. New replies are no longer allowed.