Metrics system overview dashboard redirects to a 404 Dashboard not found page in Kibana

We are using Kibana v8.10.4 and have installed elastic agent on one linux and a windows system.
I do see logs/metrics coming in and see the dashboard visualizations getting populated for the Metrics system overview dashboard. But if I click the host name in that dashboard it takes me to different page which results into a 404 dashboard not found page. Please check the attached screenshots

Is anyone experiencing the same issue and how can I fix this?

Thank you in advance.

Hi @Patr123,

Welcome back! I assume you are usingThat looks like a potential bug to me. Can you raise a GitHub bug request issue for Kibana with the details and the URL resulting in a 404 and we'll take a look.

If you need help raising the issue let me know and provide the URL generating the 404 error.

Hope that helps!

I have created the issue:


Curious if you have a proxy or changed the serverbaseURL on kibana?

Can you share what your URLs look like (sanitized if needed)

I am curious if you have updated the Assets for the System Package.

I am running Elastic Agent 8.11.3 and 8.11.4 and am not seeing any issues.

Mine is working both forward and back in Elastic Cloud

Hello @ stephenb,
My Kibana config looks like:

    server.publicBaseUrl: https://kibana.mydomain.local

Also I checked the assets for the system package and I see No Assets Found message:

Try to go under setting and reload the assets... that is not good...

I just did that and checked the assets tab but I got the same message about no assets found.

Reload that page?
Are you elastic user?

Also so perhaps you are missing the port?

The publicly available URL that end-users access Kibana at. Must include the protocol, hostname, port (if different than the defaults for http and https, 80 and 443 respectively), and the server.basePath (if configured). This setting cannot end in a slash (/).

Yes, I did reload the page, but still the same thing.
I logged with the superuser credentials.
I didn't get what you meant by Also so perhaps you are missing the port?

The document says add the port to that settings... You did not.

But I am more concerned why the assets don't show.

Got it, I added that URL as I used to get a warning as soon as I logged into Kibana.
Also I checked my dev kibana instance and I do see the assets under system integration.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.