Migrate Kibana visualizations from Ver 4.6 to Ver 5.3


(Michalkm) #1

We have a kibana 4.6 with many visualizations configured and would like to move them to a fresh install of Kibana 5.3, so .kibana is 100% ver 5.3
When doing an export of specific visualizations in 4.6 and import in 5.3, things break. The visualizations are showing in the list of available visualizations but when clicking on one of them in order to view them, we get the following error:
Error: Could not locate that visualization (id: XXX)
at SavedObject.applyESResp (https://localhost/portal/bundles/kibana.bundle.js?v=14823:29:23813)
at processQueue (https://localhost/portal/bundles/commons.bundle.js?v=14823:38:23621)
at https://localhost/portal/bundles/commons.bundle.js?v=14823:38:23888
at Scope.$eval (https://localhost/portal/bundles/commons.bundle.js?v=14823:39:4619)
at Scope.$digest (https://localhost/portal/bundles/commons.bundle.js?v=14823:39:2359)
at Scope.$apply (https://localhost/portal/bundles/commons.bundle.js?v=14823:39:5037)
at done (https://localhost/portal/bundles/commons.bundle.js?v=14823:37:25027)
at completeRequest (https://localhost/portal/bundles/commons.bundle.js?v=14823:37:28702)
at XMLHttpRequest.xhr.onload (https://localhost/portal/bundles/commons.bundle.js?v=14823:37:29634)

From a first glance, it looks like something is messed-up with the ID, something was changed in that matter between the versions.

It is not possible to recreate all of the visualizations, since we're talking about ~50 of them. We can do json changes in advance, before the actual import, but we cannot tel right now what we should change.

Any idea ?


(Jim Unger) #2

For other folk's reference, here's the issue that was filed as well.


(Michalkm) #3

I've upgraded to 5.3.1 and tried again. Still the same state. Check out the bug report, you can see the error logs per each visualization. It appears that Line charts migrated with no errors.
Area chart, Table and Heatmap are still broken.
Still looking for a workaround, if anyone has a suggestion. Changing the json outputs in order to make the import work are also an option, but still haven't figured out what to change.
Thanks


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.