Mis-match in compatibility matrices

If you look at the compatibility matrix here https://www.elastic.co/support/matrix#matrix_compatibility you see that Logstash 7.X is compatible with Beats 6.8.X -> 7.6.X but if you scroll down farther you see Beats 6.8.X is ONLY compatible with Logstash 5.6.X -> 6.8.X! Are the Beats agents 6.8.X actually compatible with Logstash 7.X? I desperately need to know as we are planning quite an extensive upgrade to Logstash 7 but have alot of 6.8 Beats agents out there. Thanks