Newbie Question - Settings Page Blank


(Ben Rodden) #1

Hello,

I'm working on settings up ELK on Windows via this tutorial: https://www.ulyaoth.net/resources/tutorial-install-logstash-and-kibana-on-a-windows-server.34/.

I have everything setup and running and the Kibana website comes up, but the settings page is completely blank. When I go to the Discover, Visualize, or Dashboard pages I get this error: Index Patterns: Please specify a default index pattern, which makes sense because I can't get to the settings page.

Does anyone have any idea what I am doing wrong?

Thanks,
Ben


(Ben Rodden) #2

This is what the error message looks like:


(Ben Rodden) #3

This is what the settings page looks like:


(luis) #4

Hi Ben,
I don't think I can help much, but these people seem to be experiencing the same problem as you : Kibana 4.3 showing blank pages after creating or deleting Indices
maybe you can find a solution there!


(Vikas Gopal) #5

I have two suggestions

  1. Use your own template rather logstash default template. Something like

{
"order": 0,
"template": "indexname",
"settings": {
"index": {
"refresh_interval": "5s",
"cache.field.type" : "soft",
"store.compress.stored" : true,
}
},
"mappings": {
"default": {
"dynamic_templates": [{
"string_fields" : {
"match" : "",
"match_mapping_type" : "string",
"mapping" : { "type" : "string", "index" : "not_analyzed","doc_values": true}
}
},{
"date_fields": {
"mapping": {
"type": "date",
"doc_values": true
},
"match_mapping_type": "date",
"match": "
"
}
},{
"geo_point_fields": {
"mapping": {
"type": "geo_point",
"doc_values": true
},
"match_mapping_type": "geo_point",
"match": ""
}
},
{
"integer_fields": {
"mapping": {
"type": "integer",
"doc_values": true
},
"match_mapping_type": "integer",
"match": "
"
}
}],
"properties": {
"@version": {
"index": "not_analyzed",
"type": "string"
},
}
},
"aliases": { "abctwoshard" : {}}
}

Make sure you have matched the index name with your template or you can use "template": "indexname*"
2) I was facing this issue on my laptop as it is on Windows 8 32 bit, I changed it and it worked .

Let me know if it works for you

Thanks
Vikas


(Mark Walkom) #6

Do you have data in ES?


(Ben Rodden) #7

Everyone, thanks for the suggestions.

I was able to get it working by going to port 5601, instead of 80 or 9200. Not sure why that is, but everything seems to be working fine now when I'm using that port.

Thanks,
Ben


(system) #8