No autorizated for monitoring error

You are not authorized to access Monitoring. To use Monitoring, you need the privileges granted by both the `kibana_admin` and `monitoring_user ` roles.

If you are attempting to access a dedicated monitoring cluster, this might be because you are logged in as a user that is not configured on the monitoring cluster.

Since Cross Cluster Search is enabled (`monitoring.ui.ccs.enabled` is set to `true`), make sure your cluster has the `remote_cluster_client` role on at least one node.


I think you should add the right roles to your user.
Specifically kibana_admin and monitoring_user.

You can find it on Stack Management-> Security-> Roles.

If it still doesn't work, you can restart Kibana.

1 Like

thank you thats i could resolve with your information i also add
node.roles: [ remote_cluster_client] in one of the yml of a node

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.