Non default x-pack permissions reset to defaults after upgrading from 5.6.1 to 5.6.2


#1

Per the subject line, when upgrading from x-pack 5.6.1 to 5.6.2 for elasticsearch, I noticed that my local passwords stopped working. I attempted to access https://IPAddress:9200 with said passwords and they didn't work either. I then tried elastic:changeme or kibana:changeme and those worked. Wanted to bring this to your attention since I've upgraded x-pack before and never experienced this behavior.


(Tim Vernum) #2

I was not able to reproduce this behaviour, not have I seen it mentioned by anyone else.

It looks like something went wrong with your upgrade and the .security index was lost somehow. Without more context it's impossible to tell whether that was due to a bug in ES/X-Pack or some sort of technical/process problem with your upgrade.

It would be helpful to understand what happened here. Can you provide more details? Feel free to send me a private message if you aren't able to post details publicly.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.