Not able to create index after first index uisng imap input plugin

Hi All

I created a index using imap plugin. It went through successfully first time
Then i realized i should change some fields type using template and i deleted the index

I re ran the logstash using same config file without doing any changes, but it is not creating index.

I suspect there is something like sincedb_file in imap also. But don't know where it is

Here is my imap config file

input {
  imap {
    host => ""
    user => ""
    password => "abc"
    port => 993
    secure => true

output {  
stdout { codec => rubydebug}
    elasticsearch { 
	   action => "index"
       hosts => ""	   
       index => "emailtest"       
       workers => 1

No one facing this problem?

I think this is common problem with all plugins in 2.3.4 logstash

I solved the problem of file using sincedb_file, but how to solve for imap?

Hi All

I tried again downloaded brand new ES and Logstash and repeated the steps.
I am able to create index for first time

after deleting and recreating the index is not possible

Anyone have solution for this????

AFAICT the imap input only processes unread messages, so to reprocess messages you'd have to mark them an unseen on the IMAP server.

Anyone have solution for this????

Please have patience.


Yes, this is working perfectly now

The mails should be unread to make it work.

Thanks a lot