Not allowed to increase reporting capture timeouts in Elastic cloud

Hello,

We are using the Elastic Cloud service. When generating a report I get the following error message:

An error occurred when trying to open the Kibana URL. You may need to increase 'xpack.reporting.capture.timeouts.openUrl'. TimeoutError: waiting for selector ".application" failed: timeout 30000ms exceeded

In the deployment page > edit > Kibana > User settings overrides

I tried to increase the value in: xpack.reporting.capture.timeouts.openUrl: 60000

It gives the following message:

'xpack.reporting.capture.timeouts.openUrl': is not allowed

Is there another way to increase this timeout?

1 Like

This issue is documented at https://www.elastic.co/guide/en/cloud/current/ec-manage-kibana-settings.html.

Just change the value of xpack.reporting.queue.timeout. The default value is 30000 (30 seconds).

I have changed xpack.reporting.queue.timeout: 600000

and now get this error : You may need to increase 'xpack.reporting.capture.timeouts.openUrl'. TimeoutError: waiting for selector ".application" failed: timeout 30000ms exceeded

If I try and change that xpack.reporting.capture.timeouts.openUrl: 600000 it says 'xpack.reporting.capture.timeouts.openUrl': is not allowed

I also tried to increase the xpack.reporting.queue.timeout but the issue remained the same

Same issue for me.

I have tried increasing xpack.reporting.queue.timeout to really high numbers, and even tried to increase the size of the Kibana instance.

I keep getting You may need to increase 'xpack.reporting.capture.timeouts.openUrl'. TimeoutError: waiting for selector ".application" failed: timeout 30000ms exceeded

We are facing with the same problem as well

After lots of different options tried through ES support the only solution that worked was to up the RAM for the kibana instance

Hi Robert,

I tried upgrading the RAM as well to 2GB's, and the screenshots now are changed to:

How many GB's of RAM did you add? We barely use Kibana. Maximum one concurrent user.

I had to go from 1 to 4GB which isn't the best given the increase in cost :frowning:

Hi Robert,

Thanks for the additional info. I have have upgraded to 4 GB's as well and then it seems to work. We regret that this is necessary, because before we upgraded to version 7.7 it has always worked well.

Hopefully Elastic will find a fix so we can downgrade back to 1 GB.

Cheers