Reporting Timeout settings do not work


(Jasper ) #1

Hi,

In Kibana, when setting timeout settings for the reporting function in kibana.yml to:

xpack.reporting.queue.timeout: ****

It will not be picked up. I set it to 600000, but it keeps saying:

There was an error generating your report for the "mydashboard" dashboard: Error: Kibana took too long to load - Timeout exceeded (30000)

What am I doing wrong, or is this a bug?


(Jasper ) #2

Hi All,

I think I actually found another issue. I am using Kibana behind an apache proxy, with password security on apache. It looks like that is the issue;: if I use the reporting function while removing it temporarily from behind the proxy, I will get the report and not the timeout.

I guess the xpack.reporting.queue.timeout will not be picked up, but behind a proxy the reporting function does not seem to work. I will create another topic on the x-pack forum.


(Brandon Kobel) #3

The xpack.reporting.queue.timeout setting is used for the queueing mechanism and it doesn't affect how long we'll wait for kibana to load, which is the timeout that you're experiencing.

Unfortunately, that timeout isn't configurable at the moment, so no settings will affect it.

The followings settings are required when hosting kibana behind a reverse proxy: xpack.reporting.kibanaServer.protocol, xpack.reporting.kibanaServer.host, xpack.reporting.kibanaServer.port


(Jasper ) #4

Hi Brandon,

Thanks for your reaction. I do have another issue with that, because I use a username/password mechanism in apache, and have no idea how to add that to one of those settings.


(Jasper ) #5

(Joe Fleming) #6

So you're enforcing Basic auth with Apache? That's not going to work with Reporting, because there is no way to tell Reporting to pass any kind of auth header.

You could set up another proxy that would inject the credentials in the request for you, and have Reporting use that proxy to side-step your auth.

If you need auth, why not just use Shield/Security? Reporting was made to work really well with it...


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.