[Help!] x-pack reporting returns timeout error


(Yu Watanabe) #1

Hello.

I would like get advice for reporting configuration.

I am getting Max attempts reached (3) when I generate report.

I have an environment which kibana is operating behind reverse proxy (nginx). All elastic components are 5.4.0 .

nginx - kibana - tribe node
               - coordinator node - master and data node

nginx and kibana is installed on same host and network setting are below.

nginx  : 0.0.0.0:80
kibana : 127.0.0.1:5601

I have configured xpack.reporting.kibanaServer.port : 80 but still getting timeout error.

According to /var/log/message , below requests are returning 200 OK .

  1. POST /kibana/api/reporting/generate/dashboard/xxxxx

  2. GET /kibana/api/reporting/jobs/list_completed_since?xxxx

Are there any other setting which I should look for ?


(Joe Fleming) #2

If you're using a reverse proxy, you may also need to specify the hostname, unless you're connecting through localhost. Whatever URL you use to connect to Kibana as a user, you need to configure in the kibana.yml file. For example, if Kibana is running at http://localhost:5601, but you connect through http://hostname.tld, you'll need to provide the hostname and the port. If you've added SSL to the proxy, you'll also need the protocol.

You can set these with xpack.reporting.kibanaServer.protocol, xpack.reporting.kibanaServer.hostname, and xpack.reporting.kibanaServer.port (which you already have).

From the description, I'm not sure you need to change anything else though. The GET and POST endpoints you shared I'd expect to work, Reporting happens in the background, as though you had a user on the same box loading Kibana through the proxy. Those routes simply talk to Kibana like any other request.

Maybe see if you can connect to the Kibana server from the box hosting Kibana, but using the proxy settings. That's effectively what reporting is trying to do, so if that connection doesn't work, that would be the cause of the error.


(Yu Watanabe) #3

@Joe_Fleming

Thank you for the reply. I found that request was somehow not properly mapped to the server block I had.

Thus, I eluded the situation by modifying the nginx configuration to have just one server block and make sure requests to KIbana are mapped to only server block that I have.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.