6.6.1 FGenerate Report failure - Headless browser failed to log in - waitForSelector timeout

I have yet to be able to use the Reporting tool successfully. Whenever I try to generate report (PDF or PNG) I get an error saying
// TimeoutError: waiting for selector "[data-test-subj="euiToastHeader"]" failed: timeout 30000ms exceeded

One thing to note is that this is done using a simple Markup visualization with a date range of last 15 minutes. So a lot of solutions online have been regarding increasing timeout or resources on the kibana server to allow this to work. I currently have 2GB heap for Kibana which should be more than enough for what I am trying to accomplish.

Looking through trace logs I can see that Kibana spins up a headless chromium browser and attempts to go to the url of the dashboard. When that occurs, kibana redirects to the login page because no login information is provided. Is this expected? Can someone confirm that this fails for them as well but reporting succeeds? and if not, is there some setting that I missed?


# Kibana is served by a back end server. This setting specifies the port to use.
server.port: {{port}}
# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "{{host}}"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy. This only affects
# the URLs generated by Kibana, your proxy is expected to remove the basePath value before forwarding requests
# to Kibana. This setting cannot end in a slash.
#server.basePath: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
# server.name: "your-hostname"

# The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.hosts: ["https://{{host}}:{{port}}"]

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "discover"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: ""***these values are stored in the kibana keystore and are no longer needed in the config file***
#elasticsearch.password: ""

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files validate that your Elasticsearch backend uses the same key files.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
elasticsearch.requestTimeout: 60000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
elasticsearch.customHeaders: { }

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 0

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
logging.dest: path\to\Kibana_Logs\Kibana.log

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
logging.verbose: true

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# The default locale. This locale can be used in certain circumstances to substitute any missing
# translations.
#i18n.defaultLocale: "en"

# X-Pack Configuration
xpack.security.enabled: true
xpack.security.encryptionKey: {{encryptionKey}}
#Do not uncomment
#xpack.monitoring.elasticsearch.ssl.ca: path/to/certs/kibana-ca.cer
xpack.monitoring.elasticsearch.ssl.certificateAuthorities: path/to/certs/kibana-ca.cer
xpack.reporting.queue.timeout: 120000
xpack.reporting.enabled: true
xpack.reporting.encryptionKey: {{encryptionKey}}
elasticsearch.ssl.certificateAuthorities: path/to/certs/kibana-ca.cer
#elasticsearch.ssl.verificationMode: certificate

Does your host/name include capital letters? I know it sounds odd but switching to lowercase may solve the issue.

Tried @lukas's answer because at this point I'm trying anything. Can't believe it worked. Any way you can append your answer with some reasoning behind why this was the cause? Would be great insight!

It looks like it was a bug that was fixed in https://github.com/elastic/kibana/pull/33020.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.