Reporting behind secured apache proxy

reporting

(Jasper ) #1

Hi all,

I try to configure the reporting function while using Kibana behind a secured apache proxy: This does not seem to work. I almost tried everything I can think of, I will explain my configuration:

Apache is redirecting traffic coming in at port 1000, to kibana who listens on port 5602, with documentroot /kibana. This all works fine. However when using this configuration for the reporting it does not work:

xpack.reporting.enabled: true
xpack.reporting.kibanaApp: "/kibana/app/kibana" << normally it will be /app/kibana but I use as root /kibana so it becomes /kibana/app/kibana/
xpack.reporting.kibanaServer.port: 1000
xpack.reporting.kibanaServer.hostname: "serverName"
xpack.reporting.kibanaServer.protocol: "http"
xpack.reporting.queue.timeout: 300000

  1. There are not settings for entering username/password
  2. If I do not use all of these settings, it does not work as well.

Maybe someone has experienced the same issue, please let me know!


Reporting Timeout settings do not work
(Brandon Kobel) #2

In what way isn't reporting working after you added those additional settings?

Are you currently using the x-pack security plugin as well? If you do so, you shouldn't be having to hardcode the username/password anywhere.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.