Number of rows in heatmap


(Boris Goldowsky) #1

I would like to be able to control the number of rows (aka y-axis buckets) in a heatmap. In this screenshot, you'll see the "size" field has been set to "7", but many more rows are displayed. If I set the number much higher, I get an error: "There are too many series defined". Am I interpreting "size" here completely wrong? Or is there a bug?

I'd appreciate any clues you can provide.

Boris


(David Snider (Kibana Design)) #2

Asked some questions from our viz team. They said that it looks like you need to flip your x and y aggregations. It's hard to see in your screenshot was X aggregates.


(Boris Goldowsky) #3

Thank you!
The X axis is: Histogram, interval 1, on a numeric field.
Following your advice, I dragged the Y axis up so that it had top priority, and then its "Size" setting was respected (in that I can control the number of rows directly).

Help me to understand what's actually happening here -- was it looking for the top 7 items in every assignment_number column, and combining all of those into the display?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.