Percentage Mode - 0-100% min/max Heat Map

Newbie here!

I am trying to create a dashboard that contains some systems reporting back with Metricbeat. Based on the input, I would like to create a heatmap that using the normalized CPU percent as the metric over time by host.

Everything seems to be working great except I cannot for the life of me figure out how to get a 0-100% min-max. Looking at the screenshots below, enabling Percentage mode seems to be the ticket but when you observe the data vs the colouring scheme, you'll notice that they're not properly reflected.

With that all said, can anyone point me in the right direction of how to get what I'm looking for?

Appreciate it!

you'll notice that they're not properly reflected.

Just to make sure I understand the question, what specifically are you noticing here? It seems in the second image with percentage mode enabled, there's one more (presumably partial) bucket that's appearing. You can get rid of this by enabling Drop partial buckets on your date histogram configuration.

It's a little confusing that the raw values you are working with here are already percentages -- so enabling percentage mode is going to display the distribution of those values relative to each other. That is, a value of 8% in your raw data is now going to appear as 100% relative to the other results in the selected time window. Is that what you were intending to do?

If not, have you tried the Set custom ranges option? Setting that from 0 to 100 might be what you are looking for.

You are exactly right, I was just overthinking the implementation. Setting custom ranges was exactly what I needed but for some reason I was trying to use the Percentage Mode.

As for the above screenshots, when you look at the mouse over, the color no longer properly corresponds to the right bucket, which is why I was getting confused. Can you shed some light as to why that would be occurring?