Port 80 is already in use. Another instance of Kibana may be running

Hi team,

I'm having problems with kibana
Currently I have kibana configured with port 80 and displaying the web interface normally. But when I change to kibana's default port, I get an error and no longer display the web interface.
I also have nginx port 80 installed on this server, but I checked and there was no conflict. Maybe it's because some kibana process is running on a node that I haven't found yet.

Help me please!

HI @Nghia_D_ng,

Not sure which process has bind this port. Probably you can check with below command

sudo netstat -tupln | grep LISTEN

It will list all ports which is in use.

Hi ashishtiwari1993,

I've tried checking everything but to no avail
Maybe due to using node process

Hi ashishtiwari1993,

Please help me!

Hi @ashishtiwari1993 ,
Please help me!

Hi @Nghia_D_ng,

I am not sure about which process has occupied your port. Could you try to re install the kibana? Just uninstall it and check still that 5601 port is blocked or not.

Hi @ashishtiwari1993 ,

<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags":slightly_frowning_face:"error","plugins","reporting","validations"],"pid":1251275,"message":"The Reporting plugin encountered issues launching Chromium in a self-test. You may have trouble generating reports."}>

<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags":slightly_frowning_face:"error","plugins","reporting","validations"],"pid":1251275,"message":"ErrorEvent {\n target:\n WebSocket {\n _events:\n [Object: null prototype] { open: [Function], error: [Function] },\n _eventsCount: 2,\n _maxListeners: undefined,\n readyState: 3,\n protocol: '',\n _binaryType: 'nodebuffer',\n _closeFrameReceived: false,\n _closeFrameSent: false,\n _closeMessage: '',\n _closeTimer: null,\n _closeCode: 1006,\n _extensions: {},\n _receiver: null,\n _sender: null,\n _socket: null,\n _isServer: false,\n _redirects: 0,\n url:\n 'ws://',\n _req: null },\n type: 'error',\n message :'socket hang up',\n error:\n { Error: socket hang up\n at createHangUpError (_http_client.js:332:15)\n at Socket.socketOnEnd (_http_client.js:435:23)\n at Socket.emit (events.js:203:15)\n at endReadableNT (_stream_readable.js:1145:12)\n at process._tickCallback (internal/process/next_tick.js:63:19) at endReadableNT (_stream_readable.js:1145:12)\n at process._tickCallback (internal/process/next_tick.js:63:19) code: 'ECONNRESET' } }"}>

<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags":slightly_frowning_face:"error","plugins","reporting","validations"],"pid":1251275,"message":"Error: Could not close browser client handle!\n at browserFactory.test.then.browser (/u01/kibana-7.9.0-linux-x86_64/x-pack/plugins/reporting/server/lib/validate/validate_browser.js:26:15)\n at process._tickCallback (internal>>

<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags":slightly_frowning_face:"warning","plugins","reporting","validations"],"pid":1251275,"message":"Reporting plugin self-check generated a warning: Error: Could not close browser client handle!"}>

Hi @Nghia_D_ng,

You can troubleshoot this by following this step. As kibana is using chrome for report generation.

Also have a look on this issue. You can one of the suggested solution.

Hi @ashishtiwari1993 ,

I have also researched your suggestion
This still doesn't seem to solve my problem
Thank you, if you have further assistance please message me

My suggestion is to get Kibana / Elasticsearch without the nginx proxy first and then only after all that works introduce the proxy.

Reduce the variables and complexities.

1 Like

@Nghia_D_ng Hi! Have you tried checking the list of processes on the host?

ps aux | grep kibana

Or try list port listeners like this

lsof -i :80 | grep LISTEN

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.