Possible networking problem?


#1

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


#3

I've searched the Kibana installation directories and don't see any log
files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markwalkom@gmail.com wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #4

KB4 logs to stdout, so once you start the binary you should see lots of
output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitkawoof@gmail.com wrote:

I've searched the Kibana installation directories and don't see any log
files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markwalkom@gmail.com wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


#5

stdout message look normal. last one says "listening on port 5061" (or
words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom markwalkom@gmail.com wrote:

KB4 logs to stdout, so once you start the binary you should see lots of
output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitkawoof@gmail.com wrote:

I've searched the Kibana installation directories and don't see any log
files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markwalkom@gmail.com
wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch
and did a GET to test it out. Everything worked. I installed kibana
next. When I test it doing "http://localhost:5061" it fails. I
inserted a TCP monitoring tool to see the traffic in both directions.
Kibana is refusing the connection with "java.net.ConnectException:
Connection refused: connect". I also run netstat and indeed port 5061 is
up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSbKpq5RhddEAGu31Zhv_LvvuG-gPjnTWWFMZX3Bcjggk3g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


#6

Here is the message output from Kibana when I start it up:

"c:\Kibana\kibana-4.0.2-windows\bin>kibana.bat
{"@timestamp":"2015-04-29T17:11:32.713Z","level":"info","message":"No
existing k
ibana index found","node_env":""production""}
{"@timestamp":"2015-04-29T17:11:32.727Z","level":"info","message":"Listening
on
0.0.0.0:5601","node_env":""production""}"

netstat is 5061 as being open with a listener but when I try
"http://localhost:5061" in browser, I get connection refused. Anyone have
a suggestion?

On Wednesday, April 29, 2015 at 8:43:57 AM UTC-7, Sitka wrote:

stdout message look normal. last one says "listening on port 5061" (or
words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom markwalkom@gmail.com wrote:

KB4 logs to stdout, so once you start the binary you should see lots of
output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitkawoof@gmail.com wrote:

I've searched the Kibana installation directories and don't see any log
files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markwalkom@gmail.com
wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch
and did a GET to test it out. Everything worked. I installed kibana
next. When I test it doing "http://localhost:5061" it fails. I
inserted a TCP monitoring tool to see the traffic in both directions.
Kibana is refusing the connection with "java.net.ConnectException:
Connection refused: connect". I also run netstat and indeed port 5061 is
up and listening.

Anyone got any ideas on this? BTW, everything is running on my
desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #7

Try 0.0.0.0 not localhost

David

Le 29 avr. 2015 à 22:29, Sitka sitkawoof@gmail.com a écrit :

Here is the message output from Kibana when I start it up:

"c:\Kibana\kibana-4.0.2-windows\bin>kibana.bat
{"@timestamp":"2015-04-29T17:11:32.713Z","level":"info","message":"No existing k
ibana index found","node_env":""production""}
{"@timestamp":"2015-04-29T17:11:32.727Z","level":"info","message":"Listening on
0.0.0.0:5601","node_env":""production""}"

netstat is 5061 as being open with a listener but when I try "http://localhost:5061" in browser, I get connection refused. Anyone have a suggestion?

On Wednesday, April 29, 2015 at 8:43:57 AM UTC-7, Sitka wrote:
stdout message look normal. last one says "listening on port 5061" (or words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom markwalkom@gmail.com wrote:
KB4 logs to stdout, so once you start the binary you should see lots of output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitkawoof@gmail.com wrote:
I've searched the Kibana installation directories and don't see any log files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markwalkom@gmail.com wrote:
What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitkawoof@gmail.com wrote:
I have installed elasticsearch and kibana. I started elasticsearch and did a GET to test it out. Everything worked. I installed kibana next. When I test it doing "http://localhost:5061" it fails. I inserted a TCP monitoring tool to see the traffic in both directions. Kibana is refusing the connection with "java.net.ConnectException: Connection refused: connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E071636D-D1AD-4BDB-8737-DAA236E38550%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


#8

https://lh3.googleusercontent.com/-3IZW2lE0qQU/VUFe6sEmjdI/AAAAAAAAAE8/GZb7WH4oimI/s1600/monScreen.png
Does no good. See attachment. I placed tcpmon in the loop to capture the
data interchange between browser and Kibana. You can see GET outgoing on
the left and the refusal on the right.

On Wednesday, April 29, 2015 at 1:31:14 PM UTC-7, David Pilato wrote:

Try 0.0.0.0 not localhost

David

Le 29 avr. 2015 à 22:29, Sitka <sitk...@gmail.com <javascript:>> a écrit :

Here is the message output from Kibana when I start it up:

"c:\Kibana\kibana-4.0.2-windows\bin>kibana.bat
{"@timestamp":"2015-04-29T17:11:32.713Z","level":"info","message":"No
existing k
ibana index found","node_env":""production""}
{"@timestamp":"2015-04-29T17:11:32.727Z","level":"info","message":"Listening
on
0.0.0.0:5601","node_env":""production""}"

netstat is 5061 as being open with a listener but when I try "
http://localhost:5061" in browser, I get connection refused. Anyone have
a suggestion?

On Wednesday, April 29, 2015 at 8:43:57 AM UTC-7, Sitka wrote:

stdout message look normal. last one says "listening on port 5061" (or
words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom <markw...@gmail.com
<javascript:>> wrote:

KB4 logs to stdout, so once you start the binary you should see lots of
output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe <sitk...@gmail.com <javascript:>>
wrote:

I've searched the Kibana installation directories and don't see any
log files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom <markw...@gmail.com
<javascript:>> wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka <sitk...@gmail.com <javascript:>>
wrote:

I have installed elasticsearch and kibana. I started elasticsearch
and did a GET to test it out. Everything worked. I installed kibana
next. When I test it doing "http://localhost:5061" it fails. I
inserted a TCP monitoring tool to see the traffic in both directions.
Kibana is refusing the connection with "java.net.ConnectException:
Connection refused: connect". I also run netstat and indeed port 5061 is
up and listening.

Anyone got any ideas on this? BTW, everything is running on my
desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/48f742f8-44b6-4b3d-8541-a0b514a4a95f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #9

If you are using all defaults settings, checked windows firewall and tried http://0.0.0.0:5601/ (and not 127.0.0.1), I don't see what is happening.
Is Kibana still running?

David

Le 30 avr. 2015 à 00:46, Sitka sitkawoof@gmail.com a écrit :

Does no good. See attachment. I placed tcpmon in the loop to capture the data interchange between browser and Kibana. You can see GET outgoing on the left and the refusal on the right.

On Wednesday, April 29, 2015 at 1:31:14 PM UTC-7, David Pilato wrote:
Try 0.0.0.0 not localhost

David

Le 29 avr. 2015 à 22:29, Sitka sitk...@gmail.com a écrit :

Here is the message output from Kibana when I start it up:

"c:\Kibana\kibana-4.0.2-windows\bin>kibana.bat
{"@timestamp":"2015-04-29T17:11:32.713Z","level":"info","message":"No existing k
ibana index found","node_env":""production""}
{"@timestamp":"2015-04-29T17:11:32.727Z","level":"info","message":"Listening on
0.0.0.0:5601","node_env":""production""}"

netstat is 5061 as being open with a listener but when I try "http://localhost:5061" in browser, I get connection refused. Anyone have a suggestion?

On Wednesday, April 29, 2015 at 8:43:57 AM UTC-7, Sitka wrote:
stdout message look normal. last one says "listening on port 5061" (or words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom markw...@gmail.com wrote:
KB4 logs to stdout, so once you start the binary you should see lots of output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitk...@gmail.com wrote:
I've searched the Kibana installation directories and don't see any log files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markw...@gmail.com wrote:
What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitk...@gmail.com wrote:
I have installed elasticsearch and kibana. I started elasticsearch and did a GET to test it out. Everything worked. I installed kibana next. When I test it doing "http://localhost:5061" it fails. I inserted a TCP monitoring tool to see the traffic in both directions. Kibana is refusing the connection with "java.net.ConnectException: Connection refused: connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/48f742f8-44b6-4b3d-8541-a0b514a4a95f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/BF0F4632-B464-4661-9DCA-38388C4D0FCB%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


#10

Yes, Kibana is out there listening on port 5061.

On Wed, Apr 29, 2015 at 9:59 PM, David Pilato david@pilato.fr wrote:

If you are using all defaults settings, checked windows firewall and tried
http://0.0.0.0:5601/ (and not 127.0.0.1), I don't see what is happening.
Is Kibana still running?

David

Le 30 avr. 2015 à 00:46, Sitka sitkawoof@gmail.com a écrit :

https://lh3.googleusercontent.com/-3IZW2lE0qQU/VUFe6sEmjdI/AAAAAAAAAE8/GZb7WH4oimI/s1600/monScreen.png
Does no good. See attachment. I placed tcpmon in the loop to capture the
data interchange between browser and Kibana. You can see GET outgoing on
the left and the refusal on the right.

On Wednesday, April 29, 2015 at 1:31:14 PM UTC-7, David Pilato wrote:

Try 0.0.0.0 not localhost

David

Le 29 avr. 2015 à 22:29, Sitka sitk...@gmail.com a écrit :

Here is the message output from Kibana when I start it up:

"c:\Kibana\kibana-4.0.2-windows\bin>kibana.bat
{"@timestamp":"2015-04-29T17:11:32.713Z","level":"info","message":"No
existing k
ibana index found","node_env":""production""}
{"@timestamp":"2015-04-29T17:11:32.727Z","level":"info","message":"Listening
on
0.0.0.0:5601","node_env":""production""}"

netstat is 5061 as being open with a listener but when I try "
http://localhost:5061" in browser, I get connection refused. Anyone
have a suggestion?

On Wednesday, April 29, 2015 at 8:43:57 AM UTC-7, Sitka wrote:

stdout message look normal. last one says "listening on port 5061" (or
words to that affect)

On Tue, Apr 28, 2015 at 5:29 PM, Mark Walkom markw...@gmail.com wrote:

KB4 logs to stdout, so once you start the binary you should see lots of
output of in your command prompt.

On 29 April 2015 at 09:23, Colleen Roe sitk...@gmail.com wrote:

I've searched the Kibana installation directories and don't see any
log files.

On Tue, Apr 28, 2015 at 3:39 PM, Mark Walkom markw...@gmail.com
wrote:

What do your Kibana logs show?

On 29 April 2015 at 07:53, Sitka sitk...@gmail.com wrote:

I have installed elasticsearch and kibana. I started elasticsearch
and did a GET to test it out. Everything worked. I installed kibana
next. When I test it doing "http://localhost:5061" it fails. I
inserted a TCP monitoring tool to see the traffic in both directions.
Kibana is refusing the connection with "java.net.ConnectException:
Connection refused: connect". I also run netstat and indeed port 5061 is
up and listening.

Anyone got any ideas on this? BTW, everything is running on my
desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b6f1a7e4-20eb-4176-97a0-50f2a1f93911%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-LcCu_99SeWYOOaLdNF%3DbTEYsxoWAfb_reOxb%2Bbs_YWg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAChkSb%2BOOkHPEBObSEeW_oFfx%3D_PJ2-D%3DJY_gY-%2BTMErAz_3FQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8EiQrcwQNdC5QnZx6iiYb9VqX4eF1jmQYp%2BXkD2C3YfA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/945640fc-33cc-4b91-8f05-cd7909f48624%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/48f742f8-44b6-4b3d-8541-a0b514a4a95f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/48f742f8-44b6-4b3d-8541-a0b514a4a95f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/BF0F4632-B464-4661-9DCA-38388C4D0FCB%40pilato.fr
https://groups.google.com/d/msgid/elasticsearch/BF0F4632-B464-4661-9DCA-38388C4D0FCB%40pilato.fr?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSbKs8DJiGks0zKM_W9_%3DmDn4gv3PJYkgyUPxP6-CgD_2Hg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Christian Dahlqvist) #11

Hi,

I think there is some confusion about the port number used. Kibana 4 by
default listens to port 5601, which based on the output sample you provided
seems to not have been changed. In all your examples you are however
looking for port 5061, not 5601. Can you check if you are able to connect
to port 5601?

Christian

On Tuesday, April 28, 2015 at 10:53:42 PM UTC+1, Sitka wrote:

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/42c0e129-7134-4785-b7ed-24ec4f962e49%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#12

You're right, I found this problem about an hour ago. There's a mistake in
a doc which I where I picked it up from. Thanks.

On Thu, Apr 30, 2015 at 9:41 AM, Christian Dahlqvist acdahlqvist@gmail.com
wrote:

Hi,

I think there is some confusion about the port number used. Kibana 4 by
default listens to port 5601, which based on the output sample you provided
seems to not have been changed. In all your examples you are however
looking for port 5061, not 5601. Can you check if you are able to connect
to port 5601?

Christian

On Tuesday, April 28, 2015 at 10:53:42 PM UTC+1, Sitka wrote:

I have installed elasticsearch and kibana. I started elasticsearch and
did a GET to test it out. Everything worked. I installed kibana next.
When I test it doing "http://localhost:5061" it fails. I inserted a TCP
monitoring tool to see the traffic in both directions. Kibana is refusing
the connection with "java.net.ConnectException: Connection refused:
connect". I also run netstat and indeed port 5061 is up and listening.

Anyone got any ideas on this? BTW, everything is running on my desktop.

Thanks.

Kibana 4.0.2-windows
elasticsearch 1.5.2

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/TWft6sC0E9U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/42c0e129-7134-4785-b7ed-24ec4f962e49%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/42c0e129-7134-4785-b7ed-24ec4f962e49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAChkSbKVWA2jf4H%2BsZzWg_nzoq0Nv7f80UWJSTsggSYC4VRTpg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #13