Problem with the size of the circles in Map

I don't understand how Kibana manages the size of proportional circles in Map.
For example I want to map data with a proportional circle linked to a variable (fatalities) so I know that the maximum value is 136. My problem is that in the legend the maximum circle corresponds to a lower value in this case 56. The circle corresponding to the point with a value of 136 is present but it is the size attributed to the maximum value in the legend, i.e. 56.

Does anyone have an idea?
Thank you.

Hello, a few questions:

  • What version of Kibana/elasticsearch are you using?
  • What is the data type of the 'fatalities' field?
  • Can you perform a query showing its results?


Version 8.7
Fatalities : "fatalities": "type": "long"
A query on Fatalities (maximum) :


By default, min and max values are clamped to be within 3 standard deviations of medium. You can see this setting under Data mapping.

You can increase standard deviations to increase the effects of the outlier on the data set.

There is a bug where the size legend does not clearly indicate that values can be great than max when clamped by standard deviation. I have created [maps] size legend does not indicate when min or max clamped by std range · Issue #156907 · elastic/kibana · GitHub to track the issue.

To view the standard deviation for the data set, click Inspect to view elasticsearch requests. Set View: Requests and locate the request name "INTERACTIONS - metadata". See image below for example metadata request response.

Well noted for the bug.
I pushed sigma to 5.
So if I understand, it's impossible to have in the legend the real max of the data selected for the map? It's strange because at the end the map is false ....

He is the result for fatalities :
"rawResponse": {
"took": 0,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"skipped": 0,
"failed": 0
"hits": {
"total": {
"value": 138171,
"relation": "eq"
"max_score": null,
"aggregations": {
"fatalities_range": {
"count": 138171,
"min": 0,
"max": 600,
"avg": 2.814686149770936,
"sum": 388908,
"sum_of_squares": 16896374,
"variance": 114.36350637156049,
"variance_population": 114.36350637156049,
"variance_sampling": 114.36433407298895,
"std_deviation": 10.694087449219802,
"std_deviation_population": 10.694087449219802,
"std_deviation_sampling": 10.694126148170731,
"std_deviation_bounds": {
"upper": 24.20286104821054,
"lower": -18.57348874866867,
"upper_population": 24.20286104821054,
"lower_population": -18.57348874866867,
"upper_sampling": 24.202938446112398,
"lower_sampling": -18.573566146570528
"isPartial": false,
"isRunning": false,
"total": 1,
"loaded": 1,
"isRestored": false

The map is not false, the scale shows statistically relevant range.

You can disable the standard deviation clamping by

  1. under Scaling, selecting "Limit results to 10,000"
  2. Then under Data mapping, disable "Get min and max from data set".

Understood, this is maybe the solution for me.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.