_recovery returned an empty response even if I have correct indices


We have around 500GB catalog every day.
We create daily-snapshots.
In my new task, I had to restore the latest snapshot on Monday and on Thursday.

My bash script works with this logic:

  1. I search in the latest snapshot for the stored index (I used curl, and from the response, I get the index name)
  2. I check our DB for this index, If it exists, just put a new alias with the actual date, If we do not have it in our DB, I restore it.

We have seven countries, so we have seven different daily-snapshot (based on the country) and in every snapshot only one index.
So... My problem. I restored the first six countries but the last one was unsuccessful.
No error message, just this:

2019-03-21 07:06:12,646 INFO      Trying Action ID: 1, "restore": Restore the latest product index
2019-03-21 07:06:12,957 INFO      Restoring indices "['product_ph_20190319']" from snapshot: snapshot_product_ph_20190321_0110
2019-03-21 07:06:13,121 INFO      _recovery returned an empty response. Trying again.

And tried, tried, tried... Like a never-ending story

in sense, I can see the correct index:

         "snapshot": "snapshot_product_ph_20190321_0110",
         "uuid": "gLnd0c3ASreBRW526WeLaQ",
         "version_id": 5060699,
         "version": "5.6.6",
         "indices": [


  • When I checked my free space on my instance, I realised there is not enough space to restore the index.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.