Remote cluster version for cross-cluster search?


(Jeffkirk1) #1

I didn't find a definitive statement about which version of Elasticsearch is required for remote clusters when implementing cross-cluster search on a 5.3.0+ cluster.

Is it possible to query a remote cluster with a significantly older Elasticsearch version, or must it also be 5.3.0 or later?

Thanks in advance for your help.


(Jason Tedor) #2

It must be 5.3.0 or later.


(Jeffkirk1) #3

Thank you!

One follow-up question: do tribe nodes have a similar version requirement? How many versions back can one go before one has to upgrade the remote clusters?

(I understand tribe nodes are scheduled for future deprecation and that cross-cluster search is the preferred method now, but I am researching both technologies as part of a due diligence effort at my job.)


(Jason Tedor) #4

Tribe nodes are pinned to the same major version. For example, a Tribe node running 5.x can talk to remote clusters that are running 5.x only.


(Jeffkirk1) #5

Thanks! You guys at Elastic are awesome.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.