Setup Alert for Kibana

I have ELK stack (version 7.9.3) system work well in Windows with default setting. I tried to configure Alert for Kibana by following steps:

  • Stop all services
  • Update the following settings in the kibana.yml configuration file:
    elasticsearch.username: "kibana"
    elasticsearch.password: "whatever"
  • Update the following settings in the elasticsearch.yml configuration file
    xpack.security.enabled: true
  • Start ElasticSearch service
  • Run command:
    E:\ELK\elasticsearch\7.9.3\bin>elasticsearch-setup-passwords -interactive
  • Open ElasticSearch page (http://localhost:9200) and try to login by using build-in user (elastic/changeme) to login but I got error: failed to authenticate user [elastic]

I think I miss some steps to setup security for ElasticSearch. Could you help?

Thanks,

I found the error in the commandline. The "interactive" parameter doesn't have "-". It should be like below:

E:\ELK\elasticsearch\7.9.3\bin>elasticsearch-setup-passwords interactive