Setup password for Elasticsearch in windows cmd


(Sravan Gottipaty) #1

Elasticsearch and kibana were running perfectly before but when I installed x-pack it started asking for the password I looked at the forums but they all were in the linux environment. I tried typing in the default username:elastic and password:changeme which dint work. Can someone please help me out with it?


(Tim Vernum) #2
  • What version of Elasticsearch are you running?
  • Did you read and follow the setup instructions for X-Pack?
  • What features of X-Pack are you planning to use? It is possible to disable security, if you don't plan to use it.

(Sravan Gottipaty) #3

I am using ES 6.2

Yes I did read the instructions most of the forms I read were based on linux environment whereas I installed ES on windows

I wanted to use Machine Learning and SQL

Please help me how to disable security in windows.

Thanks.


(rich collier) #4

set:

xpack.security.enabled: false

in your elasticsearch.yml file which is in the config directory

save and restart your cluster. For more information, see: https://www.elastic.co/guide/en/elasticsearch/reference/6.2/security-settings.html


(Tim Vernum) #5

SQL is not available on 6.2; you need to upgrade to 6.3


(Tim Vernum) #6

The "Installing X-Pack" instructions for 6.2 explain how to setup passwords as part of step 7.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.