Snapshots not running as scheduled

I configured a snapshot cron schedule and just recently it stopped running. We restarted Elasticsearch and that didn't fix it. We restarted the nodes and that also did not fix it. I re-created the policy and that also did not fix it. Because it was our non-prod environment I even deleted all of the snapshots and started over. It still wouldn't work. I've run manual backups and they all have been successful. When I look at the policy it does tell me the next snapshot will be run at the time it should run, but it never does. Any help on this would be greatly appreciated.

Are you using SLM here?

Yes I am using SLM for this. Here is what the policy currently says. When I login the next morning the snapshot wasn't created and when I look at the policy it says there were 0 failures. The successful snapshot was a manual one I ran yesterday (I tried re-creating it with a different policy name and cron schedule yesterday). This worked fine for a very long time. Only recently did it stop running the snapshots. I can run manual ones without issue.


image

What's the API output from GET _slm/policy/uatnightlysnapshots?

The output is the following. The snapshot from 1/31 is the one I ran manually yesterday.

{
  "uatnightlysnapshots" : {
    "version" : 1,
    "modified_date_millis" : 1643646275702,
    "policy" : {
      "name" : "<v781nightlysnap-{now/d}>",
      "schedule" : "0 0 8 * * ?",
      "repository" : "uatesbackup",
      "config" : { },
      "retention" : {
        "expire_after" : "7d"
      }
    },
    "last_success" : {
      "snapshot_name" : "v781nightlysnap-2022.01.31-cclyssljslwxfebbvivobg",
      "time" : 1643650817751
    },
    "next_execution_millis" : 1643788800000,
    "stats" : {
      "policy" : "uatnightlysnapshots",
      "snapshots_taken" : 1,
      "snapshots_failed" : 0,
      "snapshots_deleted" : 0,
      "snapshot_deletion_failures" : 0
    }
  }
}

Do you ahve any ideas on what to check next for this?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.