Status is green but should be yellow

configuration (One Node only)

Logstash_1.1.13
Elasticsearch_0.20.6
Apache_2.2 + passenger_module
Kibana_2

for some reason the cluster state show i have 4 nodes and the status is
green:

{
"cluster_name" : "startapp",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 1,
"active_primary_shards" : 30,
"active_shards" : 30,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

as far as i can see from:
http://chrissimpson.co.uk/elasticsearch-yellow-cluster-status-explained.html

Since i only have one Node, the status should be Yellow with one node
I tried to check Network, hostname, PTR + A record And checked
Elasticsearch configuration , still i found no reason for this to happen

What should i check next ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

It depends if you asked for replicas or not.
Could you show your index settings?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 21 août 2013 à 09:36, haim ari haimari1@gmail.com a écrit :

configuration (One Node only)

Logstash_1.1.13
Elasticsearch_0.20.6
Apache_2.2 + passenger_module
Kibana_2

for some reason the cluster state show i have 4 nodes and the status is green:

{
"cluster_name" : "startapp",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 1,
"active_primary_shards" : 30,
"active_shards" : 30,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

as far as i can see from:
http://chrissimpson.co.uk/elasticsearch-yellow-cluster-status-explained.html

Since i only have one Node, the status should be Yellow with one node
I tried to check Network, hostname, PTR + A record And checked Elasticsearch configuration , still i found no reason for this to happen

What should i check next ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

node.name: "elastic-master"

index.number_of_shards: 1
index.number_of_replicas: 0

bootstrap.mlockall: true

network.host: x.x.x.x

gateway.expected_nodes: 1

indices.memory.index_buffer_size: 25%
index.refresh_interval: 30
index.translog.flush_threshold_ops: 5000
index.store.compress.stored: true

threadpool.search.type: fixed
threadpool.search.size: 20
threadpool.search.queue_size: 100

threadpool.index.type: fixed
threadpool.index.size: 60
indices.store.throttle.type: none
indices.store.throttle.max_bytes_per_sec: 5m

index.cache.field.max_size: 5000
index.cache.field.expire: 10m

On Wednesday, August 21, 2013 10:39:18 AM UTC+3, David Pilato wrote:

It depends if you asked for replicas or not.
Could you show your index settings?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 21 août 2013 à 09:36, haim ari <haim...@gmail.com <javascript:>> a
écrit :

configuration (One Node only)

Logstash_1.1.13
Elasticsearch_0.20.6
Apache_2.2 + passenger_module
Kibana_2

for some reason the cluster state show i have 4 nodes and the status is
green:

{
"cluster_name" : "startapp",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 1,
"active_primary_shards" : 30,
"active_shards" : 30,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

as far as i can see from:

http://chrissimpson.co.uk/elasticsearch-yellow-cluster-status-explained.html

Since i only have one Node, the status should be Yellow with one node
I tried to check Network, hostname, PTR + A record And checked
Elasticsearch configuration , still i found no reason for this to happen

What should i check next ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

So you don't ask for replicas.

Every shard is fully allocated. Cluster is green.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 21 août 2013 à 10:03, haim ari haimari1@gmail.com a écrit :

node.name: "elastic-master"

index.number_of_shards: 1
index.number_of_replicas: 0

bootstrap.mlockall: true

network.host: x.x.x.x

gateway.expected_nodes: 1

indices.memory.index_buffer_size: 25%
index.refresh_interval: 30
index.translog.flush_threshold_ops: 5000
index.store.compress.stored: true

threadpool.search.type: fixed
threadpool.search.size: 20
threadpool.search.queue_size: 100

threadpool.index.type: fixed
threadpool.index.size: 60
indices.store.throttle.type: none
indices.store.throttle.max_bytes_per_sec: 5m

index.cache.field.max_size: 5000
index.cache.field.expire: 10m

On Wednesday, August 21, 2013 10:39:18 AM UTC+3, David Pilato wrote:
It depends if you asked for replicas or not.
Could you show your index settings?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 21 août 2013 à 09:36, haim ari haim...@gmail.com a écrit :

configuration (One Node only)

Logstash_1.1.13
Elasticsearch_0.20.6
Apache_2.2 + passenger_module
Kibana_2

for some reason the cluster state show i have 4 nodes and the status is green:

{
"cluster_name" : "startapp",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 1,
"active_primary_shards" : 30,
"active_shards" : 30,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

as far as i can see from:
http://chrissimpson.co.uk/elasticsearch-yellow-cluster-status-explained.html

Since i only have one Node, the status should be Yellow with one node
I tried to check Network, hostname, PTR + A record And checked Elasticsearch configuration , still i found no reason for this to happen

What should i check next ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Got it,

Thanks

On Wednesday, August 21, 2013 11:09:12 AM UTC+3, David Pilato wrote:

So you don't ask for replicas.

Every shard is fully allocated. Cluster is green.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 21 août 2013 à 10:03, haim ari <haim...@gmail.com <javascript:>> a
écrit :

node.name: "elastic-master"

index.number_of_shards: 1
index.number_of_replicas: 0

bootstrap.mlockall: true

network.host: x.x.x.x

gateway.expected_nodes: 1

indices.memory.index_buffer_size: 25%
index.refresh_interval: 30
index.translog.flush_threshold_ops: 5000
index.store.compress.stored: true

threadpool.search.type: fixed
threadpool.search.size: 20
threadpool.search.queue_size: 100

threadpool.index.type: fixed
threadpool.index.size: 60
indices.store.throttle.type: none
indices.store.throttle.max_bytes_per_sec: 5m

index.cache.field.max_size: 5000
index.cache.field.expire: 10m

On Wednesday, August 21, 2013 10:39:18 AM UTC+3, David Pilato wrote:

It depends if you asked for replicas or not.
Could you show your index settings?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 21 août 2013 à 09:36, haim ari haim...@gmail.com a écrit :

configuration (One Node only)

Logstash_1.1.13
Elasticsearch_0.20.6
Apache_2.2 + passenger_module
Kibana_2

for some reason the cluster state show i have 4 nodes and the status is
green:

{
"cluster_name" : "startapp",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 1,
"active_primary_shards" : 30,
"active_shards" : 30,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

as far as i can see from:

http://chrissimpson.co.uk/elasticsearch-yellow-cluster-status-explained.html

Since i only have one Node, the status should be Yellow with one node
I tried to check Network, hostname, PTR + A record And checked
Elasticsearch configuration , still i found no reason for this to happen

What should i check next ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.