Table in dashboards is not showing multiline logs

In Dashboad, I have created a table to show only ERROR logs' messages, but it is not showing logs with multiple lines:

If I go to Discover, I see there is a multiline log (using the same filters):

Could someone help me with this issue?

Just to complement, I am using Kibana 8.6.2 and all the rows are configured to show 1000 values, like this one:

Hi @tulio.farias

welcome to the Kibana community.
In Lens datatable by default the row height is set to 1 line, but it is possible to tell the table to either fit to content, or set a fixed lines number.

Hi @Marco_Liberati

Thanks for the answer, I have already tried to change those settings (tried every combination), but none of them fix the issue.

The problem is not related by fitting or truncating rows, my case is that the table is not showing the rows that have the message field with multiple lines. It is only showing rows that have just 1 line.

Is that possible it is not showing due to table limitation of lines/characters per row? That log in my fist snap has 1188 characters, 22 lines.


I've tried to reproduce the issue with a JS log with the auto fit and it seems to work:

Maybe there's something in the string which hijacks the setting? Can you reproduce the issue with a minimal set of the string (you can use a runtime field to quickly prototype)?

Hi @Marco_Liberati,

I did some tests and I found out that it is happening due to a limitation of the number of the characters, that seems to be 200 (EDIT: 259) characters. If my field have more than 200 (EDIT: 259) characters, it will not been shown in the dashboard table.

I have sought for this configuration in Kibana "Advanced Settings" but I could not find it. The most close setting is below, but it is set unlimited:

So, where can I configure this maximum characters of the field to the row to be shown in Kibana's table?

EDIT: Actually, after more tests, the maximum number of characters is exactly 259. I have sought for "259" and "260" in the settings, but no results.
Just to remember, I can see all the rows in "Discover", even the lines that have more than 259. This issue is only happening in Dashboard tables.

You mean 259 char in a single line is the limit?

I did for single line, no problem. It appears on Kibana 259 or 260 char.
The char limiting seems to happen just for multiline logs.
For single line:


Kibana 259 is EOL and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

For multiline:



Do you have any idea what is happening?

@tulio.farias I tried to reproduce this and couldn't. Do you see what I was doing wrong?

Feel free to open a bug report for us to take a look at. Be sure to include examples of the exact data that is causing the problem and we can work from there!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.