The First Run of Kibana 4 makes Elasticsearch crash


I tried several times to migrate to kibana 4 but every time I access the interface and configure the indice pattern, kibana will load forever until Elasticsearch crashes around 10 min later. Then Kibana 4 shows an error page.

Since this is a migration, I have about 500 open indices, most of them weighting around 60Mio. I am suspecting Kibana 4 to query them all at once, leading to heap space problems.

How do I configure Kibana 4 to be less agressive toward Elasticsearch on its first run?

Thanks for your help

What do the ES and KB logs show?

See here for the logs:

To be more specific, Elasticsearch does not completely crash, but it is as is: you have to use a kill with the "-9" flag to stop it, and before that, all queries will just handle forever until the following screen displays

I tried to give more memory to the vm, but did nothing.

It's probably because by default it's attempting to query logstash-*, rather than time based indexing. You have to enable that. (Should be setup that way be default.)

The bug happens during the initial setup after I have specified this is a time based indexing. I never manged to reach the end of the initial setup with kibana 4