The reporting job failed + Error: Max attempts (3) reached for job X. Failed with: Error: Unable to get index-pattern

Hello World!

I'm trying to:

yet while trying to run report (using "added*" index-pattern), getting the following error:

The reporting job failed
Error: Max attempts (3) reached for job X. Failed with: Error: Unable to get index-pattern

My "custom_reporting_user" role:

GET /_security/role/_reporting-XYZ

  "_reporting-XYZ" : {
    "cluster" : [ ],
    "indices" : [
        "names" : [
        "privileges" : [
        "field_security" : {
          "grant" : [
          "except" : [ ]
        "query" : """{"bool":{"must":[{"match_phrase":{"tag":{"query":"XYZ"}}}]}}""",
        "allow_restricted_indices" : true
    "applications" : [ ],
    "run_as" : [ ],
    "metadata" : { },
    "transient_metadata" : {
      "enabled" : true

I don't have any issues when report run as "superuser", only user with _reporting-XYZ role assigned.

Please advise)
Thank you in advance)

Now using a different custom_reporting_user role and with a completely relaxed query, I was able to generate one report somehow, and the next report failed with a slightly different error:

Error: Max attempts (3) reached for job X. Failed with: Error: Saved object [index-pattern/XYZ] not found

P.S. I did saved the object before attempting to generate CSV report.

Hi @alexus ,

I believe this section of our reporting troubleshooting will be helpful to solve the problem you're facing Reporting troubleshooting | Kibana Guide [8.3] | Elastic


Thank you for looking into my topic.

The link you provided is to reference to creating a PDF or PNG report, however in my case, I'm trying to generate CSV report instead.

I did set xpack.reporting.queue.timeout (2m) and xpack.reporting.kibanaServer.port, xpack.reporting.kibanaServer.protocol and xpack.reporting.kibanaServer.hostname to their respective values, unfortunately that did not help...

back to square zero(

I may have another clue...

In "Report Info", under "Processed by", I'm seeing another Kibana instance, instead of the one where report was initiated at the first place.

still get errors (even after setting xpack.reporting.index)

Hi, do the different kibana instances have different kibana.yml settings?

Most importantly, you will hit errors if you use a different kibana.index. If you use the separate instance to create a separated space for saved objects, you will need to:

  1. check out the "Reporting index setting" documentation: Reporting settings in Kibana | Kibana Guide [7.17] | Elastic
  2. consider using Spaces for separating saved objects, and keep kibana.index and reporting.index the same in all Kibana instances.


.. while all of the Kibana instances are using same kibana.yml file, the values for some keys are set respectively, which includes kibana.index and xpack.reporting.index values.

I'm already using spaces, however in my case space still resides in it's own index set by kibana.index value, which I plan to change by migrating all spaces into fewer or single index.

I tried to set different value for xpack.reporting.index on one of Kibana instance, however even though I do see value is set to .reporting-XYZ and respective index was created, the report was still processed by different by Kibana instance, which has default value for xpack.reporting.index - (.reporting).

It's like Kibana instance isn't respecting it properly or something else..

I believe I figured it out; the following needs to be present if you running multiple Kibana instances:




This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.