Unable to generate report / Max attempts reached

Hi Team!
I am trying Generate a PDF for my Dashboards, however I am getting the follow errors over Kibana/reporting. Appreciate any help!
Message:
Unable to generate report / Max attempts reached (3)
Job info:
Created By elastic
Created At 2020-01-02T21:26:38.334Z
Started At 2020-01-02T21:34:46.151Z
Completed At 2020-01-02T21:38:49.171Z
Processed By kibana (cac95fa9-e8a6-45f6-b44d-a9d0693fe545)
Browser Timezone America/Sao_Paulo
Title 2019-ICD Metrics
Type dashboard
Layout preserve_layout
Dimensions Width: 1198 x Height: 1268
Job Type printable_pdf
Content Type n/a
Size in Bytes n/a
Attempts 3
Max Attempts 3
Priority 10
Timeout 240000
Status failed
Browser Type chromium

I am using Kibana 7.5 ( https://github.com/deviantony/docker-elk ) .
Already tried increase timeout at kibana.yml but still no luck.

##########Below the kibana.yml ##########
server.name: kibana
server.host: "0"
elasticsearch.hosts: [ "http://elasticsearch:9200" ]
xpack.monitoring.ui.container.elasticsearch.enabled: true
xpack.reporting.enabled: true
xpack.reporting.queue.timeout: 240000
logging.verbose: true
X-Pack security credentials

elasticsearch.username: elastic
elasticsearch.password: xxxxxx
########## kibana.yml ##########

Click here to see Kibana logs.
Appreciate any help!
Mauricio

I don't see anything wrong with your config at all. This is interesting. cc @tsullivan can we get some help here please? Thanks!

I think there is a known problem with using this:

The Reporting plugin uses the server.host name to open a page to Kibana, which requires authentication. The Chromium browser has been found to change the address from http://0:5601 to http://0.0.0.0:5601 which causes the Reporting plugin to prevent sending the authentication headers, and the timeout therefore is happening while waiting on the Login page.

You can confirm this by looking at the URLs that get requested in the verbose logs of the Kibana server - (sorry but the pastebin link is not working right now)

The recommendation is to change server.host to 0.0.0.0 not simply "0". BTW no quotes are needed for this setting in the kibana.yml.

There is also a xpack.reporting.kibanaServer.hostname setting that will override the default setting: https://www.elastic.co/guide/en/kibana/current/reporting-settings-kb.html#reporting-kibana-server-settings -- but in this case it should be fine to just change the server.host to a value that Reporting can use.

3 Likes

Hey Tim!
Fantastic! It worked perfectly following your suggestion. Thank you so much!

kibana.yml
server.host: 0.0.0.0

Btw, Can I cleanup the failed Jobs under Management/Reporting ?

Regards, Mauricio

Hi Mauricio,

For now, the only way available to clean up any kind of reporting job document is to use Elasticsearch query DSL. You can run a delete_by_query in the Console app in Dev Tools to remove all the jobs that have "status": "failed":

POST /.reporting-*/_delete_by_query
{
  "query": {
    "term": {
      "status": {
        "value": "failed"
      }
    }
  }
}
2 Likes

Worked perfectly Tim! Thank you so much!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.