This interval creates too many buckets


(Krzysztof Grabowski) #1

Hello,
I'm not able to customize Date Histogram interval.

In the past there was an option called pre_zone_adjust_large_interval but it's no longer available (unknown field [pre_zone_adjust_large_interval], parser not found). I need to make the interval 1 second. I don't care a graph will be distorted or too crowded. I want to force this behaviour knowing all the disadvantages.

What can be done to force it?


(Nathan Reese) #2

pre_zone_adjust_large_interval was deprecated in 1.5 and has been removed.

You can adjust histogram:maxBars under Management -> Advanced Settings. The interval is scaled if the number of buckets created by the interval exceeds this number. Do set this number to a crazy large number because it could cause problems in Elasticsearch and Kibana.


(Krzysztof Grabowski) #3

Cool. Thanks for help :slight_smile:


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.