Time Filter in Kibana Disappeared for Some Users

Hey all!

Ran into a little issue with my Kibana instance that I'm hoping the wonderful community can help me out with.
I created a new space and roles for a group of users to look at logs specific to their groups' work needs and, for some reason, they can't see the time filter in Kibana at all. They can still see the search bar, but no time range adjust-er. They tried clicking around on the screen to see if it popped up, tried different browsers, and I checked their permissions against other roles/spaces I've made, and I can't find a difference. When I login, I can see the time filter no problem, so it leads me to believe that there is a permission somewhere that I have checked but have overlooked.

Any help is greatly appreciated!

Thanks all!

What version?

Are you talking about Discover for instance.

Click in / out of the KQL Search Bar... The time picker should show up again ... UI Glitch / bug.

I have seen that before.

If it's not that can you provide a screenshot or two??

Hey Stephenb, we're using version 7.16.1. And yes, the filter in Discover.

We've tried having them click in-and-out of the Search Bar, but no luck there.

Unfortunately, I won't be able to provide a screenshot given the nature of my environment. Sorry!!

You can open that bug report and do your best to describe it. Of course, generally with UI issues, we would ask for a screenshot and potentially any output from the developer tools in the browser.

If you just create a space with all the default roles and permission just to test, do they see the same issue?

I'm not sure how a role or permission removes the time picker. I would have to think about that a bit.

So I did some more tests:

I added some people that have never used Elastic before and they are also unable to see the time filter. I even tried giving their role in Kibana "all" cluster privileges, but that didn't work.
I also gave them visibility into the Default space, and still they were unable to see the filter, which makes me think it's a roles thing.

I added another user who is in other Kibana groups, and he was able to see the time filter. Not sure if some setting from another role is overriding the other space he's going into or what.

I've made all the settings completely identical, with no luck. Not sure what else to try besides tearing the group down and setting it back up again. haha

Can you share the role definitions?

Silly thought... If a uses only has access to data / index patterns without timestamps then the time picker does not show up... is that the Case?

Note here is an example of a view with data with no timestamps OR timestamp is not set in index pattern... No Time Picker.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.