Timelion date format


(Carlosvega) #1

When using "auto", Timelion shows only the hour and not the date for long spans of times such as now-10d to now is there any way to fix this?

Greetings


(Tim Sullivan) #2

I wasn't able to reproduce that issue. I didn't see any issues for it in the Github repo either.

  • Which version of Kibana is this?
  • Is the screenshot from a Dashboard, in the Timelion chart builder or in a Timelion sheet?
  • Can you share your expression?

(Carlosvega) #3

With which time spans have you tried?
If you use now-7d and small time spans, it happens.

Which version of Kibana is this?

4.6.4

Is the screenshot from a Dashboard, in the Timelion chart builder or in a Timelion sheet?

The screenshot is from a kibana dashboard but it does happen as well in the timelion builder and the kibana timelion builder (it is saved to support kibana queries)

Can you share your expression?

Here it is

.es(index="traffic*bps", metric="avg:bps_in", split="interfaz_id:10").divide(1000000).label('Incoming traffic, interface $1', '.*:(.*)>.*').points(1, 2, show=true).lines(2, show=true).yaxis(label='Mbps').legend('nw', 3), 

.es(index="traffic*bps", metric="max:bps_in", split="interfaz_id:10").divide(1000000).label('Max. incoming traffic, interface $1', '.*:(.*)>.*').points(1, 2, show=true).lines(2, show=true).yaxis(label='Mbps').hide(), 

.es(index="traffic*bps", metric="avg:max_interface").divide(1000000).label('Max.').points(1).color('red').hide()

Thanks !


(Tim Sullivan) #4

I'm using Kibana 5.5.0 and I've tried last 10 years and last 5 years. I've tried various selections of the bucket interval sizes, and even tried a few different data sets I have. I used some splits and label regexes and Y-Axis labels. I couldn't get this to happen in the Timeline builder, trying with fullscreen as well, or embedded in a dashboard.

Unfortunately it doesn't look like there are any specific changes in the Kibana Github repo that would have addressed this issue, but there is the possibility that there was an unrelated change or dependency upgrade that would have fixed this.

Would you be be to test in a newer version of Kibana?


(Carlosvega) #5

It happens with small spans, like now-10d to now or 1 week. With bigger spans it shows the dates


(Tim Sullivan) #6

Oops, my mistake!

I tried with some historical data, and used absolute times in the time picker. I actually do see this now, and I'm still using Kibana 5.5.0.

I could get it to happen when I'm looking at a time window of 2-5 days, but at 6 days and higher, I don't see it.

It looks like a valid bug, and I didn't see any record of it in the Kibana Github, so I filed a bug report for it: https://github.com/elastic/kibana/issues/13065


(Carlosvega) #7

Thanks for opening the issue :slightly_smiling_face:
It would be great being able to change the date format with an .xaxis option.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.