Too many shards with Timelion


I'm trying to visualise some data with Timelion.

It is working well, until i want to parse a .if() condition.

Then i have a "too many shards error". I tried something very simple for the test

.es(index= test-rabbitmqinput-* ).if(eq,.es(index= test-rabbitmqinput-*,metric=max:Temp),0,null)

but still i have the same error, requesting 1190 shards out of the 1000 authorised...

I don't understand why there is so many shards needed. I have only 2 index to query, with 5 shards each, and there is one data per minute in a 2h time frame. It is not so many data, so why is 1190 shards requested ?

Is the metric max the problem ?

What time range are you using?

1m, but i tried also 1h and 1d to see if it is changing something. But even with 1d, it still demands 1190 shards

ok actually it is working with the above query.


.es().if(eq,.es(index= test-rabbitmqinput-*,metric=max:Temp),0,null)

is giving the error, or anything involving .es()

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.