Training Subscription : Online training issue - Elasticsearch Engineer 1

Hi guys:
I ran into 2 issues when I did the Online Training for Elasticsearch Engineer 1, see below:

  1. The Kibana is currently down, look like it’s currently down
    http://ec2-18-195-11-38.eu-central-1.compute.amazonaws.com/app/kibana#/management?_g=()

  2. The Logstash start-up errors (see attached) after I ran this command, ./logstash-7.8.0/bin/logstash -f datasets/blogs_sql.conf

Please advise, thanks

Hi Suselena,

Your logs says that you don't have an instance of Elasticsearch running. Every time you pause your lab environment, you need to rerun all the process you had before like Kibana and Elasticsearch.

You can see the instruction in how to start Elasticsearch at Lab 1.2:

Start Elasticsearch:

./elasticsearch-7.8.0/bin/elasticsearch

How to start Kibana at Lab 1.3:

Start Kibana:

./kibana-7.8.0-linux-x86_64/bin/kibana --host=0.0.0.0

Please, let me know if it worked for you or if you need any further assistance.

Have a great Lab

Thanks Tamara. Sorry for the silent because I just some time to catch up with my study now. How would I check if both Elasticsearch and Kibana are running? I'm getting the 502 gateway error and see attached for the Elasticsearch errors. Thanks.

Guess what, Tamara. It's working now and I don't see the Elastic error anymore lol Magic

That's great. You know sometimes it's like this.

I am glad you can properly start your course now. If you have any doubts about the course just open a new issue, and we are glad to help.

1 Like