Kibana will not load

Hi, I'm taking the "Understanding and Controlling Relevance" course remotely, and I cannot access kibana. When I click the kibana link shown on the page here: http://ec2-18-196-225-250.eu-central-1.compute.amazonaws.com/instructions/index.html, I get a 502 bad gateway. Can someone please help me?

I've also tried to just run the labs locally (according to the guide here): http://ec2-18-196-225-250.eu-central-1.compute.amazonaws.com/instructions/setup_local.html, and it references a zip file named "Understanding_and_Controlling_Relevance-6.3.0.zip" which seems to have the data for the labs. However, I cannot seem to find this zip anywhere in the course materials. Can someone point me to it? Thank you.

Hello Joshua,

I‘m sorry to read that you are having issues with the class. If I‘m not mistaken we no longer provide the zip-file. But it should be straight forward to get your issues resolved.

First check: did you start Kibana? It‘s an expected behavior to get back 502 Bad Request if Kibana isn‘t running

Second check: when you started Kibana, did you bind it to port 0.0.0.0 to make your Kibana instance accessible? Not binding it to 0.0.0.0 also results in a 502 Bad Request response.

Please check and let us know

Daniel

Hi Daniel -- No I have not started Kibana. How do I do that? I don't see kibana anywhere on my workstation. My strigo thing does not have anything in the sidebar as the instructions indicate, and when i tried to find kibana on the filesystem I couldn't locate it.

Oh nevermind -- I wasn't looking at the instructions!

Ok, that explains the „502 Bad Request“. As you found the (lab) instructions, are you ok now?

What version of KB did you install?

This post was flagged by the community and is temporarily hidden.

Hi Daniel, Yes, all set now! Thank you.

1 Like