Transport_address not matching unicast host values

Hi Elastic Search users,

We are seeing a rather strange issue. I have reviewed the email archives
and I do not see this issue addressed already. We
have discovery.zen.ping.multicast.enabled: false in our elasticsearch.yml.
The cluster comes up and the state is green, and the nodes are aware of
each other.

The strangeness is that the transport_address value returned in the cluster
state query does not match the values in discovery.zen.ping.unicast.hosts -
it is using a different interface on the machines.

Does anyone have any insight? Would be happy to pastebin all of these
results.

Thanks,
Joe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Values in discovery.zen.ping.unicast.hosts are used only for initial
discovery. In other words they are used by a node to find other nodes in
the cluster. An interface that a particular node is binding to or
publishing for other nodes to use doesn't depend on
discovery.zen.ping.unicast.hosts but instead it is controlled by
network.host, network.bind_host and network.publish_host settings.
See http://www.elasticsearch.org/guide/reference/modules/network/ for more
information.

On Thursday, August 15, 2013 12:15:32 PM UTC-4, Joseph Hammerman wrote:

Hi Elastic Search users,

We are seeing a rather strange issue. I have reviewed the email archives
and I do not see this issue addressed already. We
have discovery.zen.ping.multicast.enabled: false in our elasticsearch.yml.
The cluster comes up and the state is green, and the nodes are aware of
each other.

The strangeness is that the transport_address value returned in the
cluster state query does not match the values in
discovery.zen.ping.unicast.hosts - it is using a different interface on the
machines.

Does anyone have any insight? Would be happy to pastebin all of these
results.

Thanks,
Joe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.