Trouble with install on Ubuntu 14.04


(Paul Starrett) #1

I tried to install ES on m Ubuntu box and must have made a wrong turn somewhere. I downloaded the deb file and then went to CL and entered bin/elasticsearch. It seemed to kick off nicely but then it hanged. I also seem to have found another install of ES as well. I would like to uninstall everything and then find a location with proper download and install instructions for my OS that work. Thank you!


(Mark Walkom) #2

Check out https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-repositories.html


(Niraj Kumar) #3

If you downloaded the debian file , shouldn't you use sudo service elasticsearch start ? I believe if you download a tar.gz then only you go on using bin/elasticsearch.

Btw can you specify the download link and the version you tried to install.

Regards
Niraj


(Paul Starrett) #4

Niraj, thanks, buddy, this did it! It starts.


(Paul Starrett) #5

I started with an attempt to install the public key from this site which did not work (got CL error that there is no such directory). However, the next reply to this post solved my problem. I will definitely keep this link as it looks very informative and may come in handy. Thank you very much!


(system) #6