Trying to create a new beat - pip install functools32 error


(Ravi R) #1

Hi,
I am attempting to create a beat, so i am following the steps listed in :
https://www.elastic.co/guide/en/beats/devguide/current/newbeat-generate.html

And i get this error in the "make setup" step:
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-3s2cmdxv/functools32/

Can someone gimme pointers on how to get over this error please ?

My environment and logs:

sprint @ mybeat>python --version
Python 2.7.12

sprint @ mybeat>lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

sprint @ mybeat>make setup
mkdir -p vendor/github.com/elastic/
cp -R /home/ravir/go//src/github.com/elastic/beats vendor/github.com/elastic/
rm -rf vendor/github.com/elastic/beats/.git vendor/github.com/elastic/beats/x-pack
make update
make[1]: Entering directory '/home/ravir/go/src/github.com/toravir/mybeat'
test -d /home/ravir/go/src/github.com/toravir/mybeat/build/python-env || virtualenv /home/ravir/go/src/github.com/toravir/mybeat/build/python-env
Using base prefix '/usr'
New python executable in /home/ravir/go/src/github.com/toravir/mybeat/build/python-env/bin/python3
Also creating executable in /home/ravir/go/src/github.com/toravir/mybeat/build/python-env/bin/python
Installing setuptools, pip, wheel...done.
. /home/ravir/go/src/github.com/toravir/mybeat/build/python-env/bin/activate && pip install -q --upgrade pip ; \
if [ -a ./tests/system/requirements.txt ] && [ ! ./vendor/github.com/elastic/beats/libbeat/tests/system/requirements.txt -ef ./tests/system/requirements.txt ] ; then \
. /home/ravir/go/src/github.com/toravir/mybeat/build/python-env/bin/activate && pip install -qUr ./vendor/github.com/elastic/beats/libbeat/tests/system/requirements.txt -Ur ./tests/system/requirements.txt ; \
else \
. /home/ravir/go/src/github.com/toravir/mybeat/build/python-env/bin/activate && pip install -qUr ./vendor/github.com/elastic/beats/libbeat/tests/system/requirements.txt ; \
fi
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-ibmhreis/functools32/
vendor/github.com/elastic/beats/libbeat/scripts/Makefile:231: recipe for target 'python-env' failed
make[1]: *** [python-env] Error 1
make[1]: Leaving directory '/home/ravir/go/src/github.com/toravir/mybeat'
Makefile:19: recipe for target 'setup' failed
make: *** [setup] Error 2
sprint @ mybeat>

Thanks!


(Noémi Ványi) #2

What is your version of setuptools?

With Python 2.7.13 and setuptools 33.1.1 it works on my machine.


(Ravi R) #3

I switched to a different machine - similar env, it worked fine.

my setuptools version: 39.1.0

I am continuing to use the other machine (where it worked).


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.