Trying to set up ELK, get " This version of Kibana requires Elasticsearch ^2.3.0 on all nodes..."

Hi -- Please pardon me if this is a newbie error, but I am trying to set up Elasticsearch, Logstash, and Kibana on a Red Hat Linux 6.x system. I am using the RPM repositories and I tried to follow the instructions on these pages:

After successfully setting up the yum repos and installing all three components (apparently without error) and starting things up, I go the the Kibana URL (http://localhost:5601/app/kibana) and I get a status display where everything looks OK except that under "Installed Plugins" > plugin:elasticsearch, it says:

This version of Kibana requires Elasticsearch ^2.3.0 on all
nodes. I found the following incompatible nodes in your cluster:
Elasticsearch v2.2.1 @ (

I'm struggling to understand what to do about this. Can anyone advise?

My intuition is that I need a newer version of Elasticsearch (2.3), but I can't see how to specify that in my repo definitions since it looks like the same repo definition is used for all 2.x versions. I tried uninstalling and reinstalling Elasticsearch but that had no effect (which I expected, since I hadn't changed anything in the repo defintions).

What does rpm -qa|grep elasticsearch show?

It shows:

...confirming that the error message from Kibana is correct -- the version of Elasticsearch is in fact the older one (2.2.1) which it (Kibana) does NOT want., this leaves us with the question: how do I get yum to install the newer elasticsearch version (2.3, which Kibana does want)?

Try a yum update then yum upgrade?

1 Like

(As you English would say): BRILLIANT!!

That fixed it.

When I did the 'yum update' it uninstalled elasticsearch 2.2.1 and installed I retried the Kibana UI but it still showed the error, but I figured that was probably because something needed to be restarted. Rather than fiddle with it I just restarted the machine, and now it's fine. Visiting the Kibana start page I do not see the error, and 'rpm -qa | grep elasticsearch' shows the expected version (2.3).


Any idea why this happened? I know this is probably a Red Hat Linux maintenance thing and not an Elasticsearch thing as such, but I would appreciate it if someone could educate me so I won't stumble in the same way the next time I try to do something like this...

System maintenance is still a bit a mystery to me on Red Hat; I'm pretty good with the procedures on debian/Ubuntu but Red Hat kind-of throws me.

Thanks again!

1 Like