Kibana 3 unable to connect to elasticsearch


(Brian Wilkins) #1

I am on RHEL 6. I can send messages from my Logstash shipper to Redis to
Elasticsearch. I installed logstash via RPM on all my servers and I
installed elasticsearch 1.0.3 via RPM. When I issue the command via curl to
check my node status, I get two different versions. In Kibana 3, it tells
me that "Your version of Elasticsearch is too old. Kibana requires
Elasticsearch 0.90.9 or above." As you can see, I am running a version
greater than 0.90.9. Kibana also tells me that "Could not reach
http://[elastic-search-hostname]:9200/_nodes. If you are using a proxy,
ensure it is configured correctly". I am not using a proxy.

Any idea what is wrong?

$ curl http://[elastic-search-hostname]:9200/_nodes/process?pretty

{
"cluster_name" : "logstash",
"nodes" : {
"43V635FUQ46pksH9yZ8SuA" : {
"name" : "logstash-[hostname]-23165-2010",
"transport_address" : "inet[/[logstash-central-server:9300]",
"host" : "[hostname]",
"ip" : "[logstash-central-server]",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 23165,
"max_file_descriptors" : 16384,
"mlockall" : false
}
},
"tV3Qwo-YRu-m_GUDZq5flQ" : {
"name" : "[hostname]",
"transport_address" : "inet[/[elastic-search-host:9300]",
"host" : "[hostname]",
"ip" : "[elastic-search-ip]",
"version" : "1.0.3",
"build" : "61bfb72",
"http_address" : "inet[/[elastic-search-host]:9200]",
"process" : {
"refresh_interval" : 1000,
"id" : 3334,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53fdd8a0-5f61-41c7-8551-441ff6e225ee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

It'll help if you can gist/pastebin your config for kibana.
Also install a monitoring plugin like Marvel or ElasticHQ to give yourself
better insight into your cluster.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 May 2014 23:08, Brian Wilkins bwilkins@gmail.com wrote:

I am on RHEL 6. I can send messages from my Logstash shipper to Redis to
Elasticsearch. I installed logstash via RPM on all my servers and I
installed elasticsearch 1.0.3 via RPM. When I issue the command via curl to
check my node status, I get two different versions. In Kibana 3, it tells
me that "Your version of Elasticsearch is too old. Kibana requires
Elasticsearch 0.90.9 or above." As you can see, I am running a version
greater than 0.90.9. Kibana also tells me that "Could not reach http://[elastic-search-hostname]:9200/_nodes.
If you are using a proxy, ensure it is configured correctly". I am not
using a proxy.

Any idea what is wrong?

$ curl http://[elastic-search-hostname]:9200/_nodes/process?pretty

{
"cluster_name" : "logstash",
"nodes" : {
"43V635FUQ46pksH9yZ8SuA" : {
"name" : "logstash-[hostname]-23165-2010",
"transport_address" : "inet[/[logstash-central-server:9300]",
"host" : "[hostname]",
"ip" : "[logstash-central-server]",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 23165,
"max_file_descriptors" : 16384,
"mlockall" : false
}
},
"tV3Qwo-YRu-m_GUDZq5flQ" : {
"name" : "[hostname]",
"transport_address" : "inet[/[elastic-search-host:9300]",
"host" : "[hostname]",
"ip" : "[elastic-search-ip]",
"version" : "1.0.3",
"build" : "61bfb72",
"http_address" : "inet[/[elastic-search-host]:9200]",
"process" : {
"refresh_interval" : 1000,
"id" : 3334,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53fdd8a0-5f61-41c7-8551-441ff6e225ee%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53fdd8a0-5f61-41c7-8551-441ff6e225ee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624Z5c0%2BEiVF8viwo6SNNRwdd6%3DDEex-nT%2BKjtOauvEK%3DZQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Brian Wilkins) #3

Thanks for the tips. It turns it that it was a DNS issue. But I am
going to install one of those tools.

On Fri, May 9, 2014 at 5:22 PM, Mark Walkom markw@campaignmonitor.com wrote:

It'll help if you can gist/pastebin your config for kibana.
Also install a monitoring plugin like Marvel or ElasticHQ to give yourself
better insight into your cluster.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 May 2014 23:08, Brian Wilkins bwilkins@gmail.com wrote:

I am on RHEL 6. I can send messages from my Logstash shipper to Redis to
Elasticsearch. I installed logstash via RPM on all my servers and I
installed elasticsearch 1.0.3 via RPM. When I issue the command via curl to
check my node status, I get two different versions. In Kibana 3, it tells me
that "Your version of Elasticsearch is too old. Kibana requires
Elasticsearch 0.90.9 or above." As you can see, I am running a version
greater than 0.90.9. Kibana also tells me that "Could not reach
http://[elastic-search-hostname]:9200/_nodes. If you are using a proxy,
ensure it is configured correctly". I am not using a proxy.

Any idea what is wrong?

$ curl http://[elastic-search-hostname]:9200/_nodes/process?pretty

{
"cluster_name" : "logstash",
"nodes" : {
"43V635FUQ46pksH9yZ8SuA" : {
"name" : "logstash-[hostname]-23165-2010",
"transport_address" : "inet[/[logstash-central-server:9300]",
"host" : "[hostname]",
"ip" : "[logstash-central-server]",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 23165,
"max_file_descriptors" : 16384,
"mlockall" : false
}
},
"tV3Qwo-YRu-m_GUDZq5flQ" : {
"name" : "[hostname]",
"transport_address" : "inet[/[elastic-search-host:9300]",
"host" : "[hostname]",
"ip" : "[elastic-search-ip]",
"version" : "1.0.3",
"build" : "61bfb72",
"http_address" : "inet[/[elastic-search-host]:9200]",
"process" : {
"refresh_interval" : 1000,
"id" : 3334,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53fdd8a0-5f61-41c7-8551-441ff6e225ee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/ShUxMVg-PHk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624Z5c0%2BEiVF8viwo6SNNRwdd6%3DDEex-nT%2BKjtOauvEK%3DZQ%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAO_Eq30c91wCs%2BxsVOG%2BUckwNvKLXKvzPhUes2VQ8g%2Bca0zbeA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4