Kibana has problems connecting to Elasticsearch


(Dušan Đorđević) #1

Hi,

I downloaded elasticsearch-1.0.1.noarch.rpm,
logstash-1.4.0-1_c82dc09.noarch.rpm and kibana-3.0.0.tar.gz from
http://www.elasticsearch.org/overview/elkdownloads/ and installed them on
RHEL 6 with Apache and self signed http cert.

I replaced default Kibana dashboard with logstash dashboard that comes with
Kibana (cp logstash.json default.json in kibana/app/dashboards)

When I connect from another machine's browser to
https://10.142.4.104/kibana I get following error message:

Could not reach http://10.142.4.104:9200/_nodes. If you are using a proxy,
ensure it is configured correctly

However from that same machine curl http://10.142.4.104:9200/_nodes works
without any problems, and one with pretty output also:

curl 10.142.4.104:9200/_nodes/process?pretty
{
"cluster_name" : "aerlingus",
"nodes" : {
"avemXrb9SB6lxgxgL54ecA" : {
"name" : "central-log-server",
"transport_address" : "inet[/10.142.4.104:9300]",
"host" : "central-log-server",
"ip" : "10.142.4.104",
"version" : "1.0.1",
"build" : "5c03844",
"http_address" : "inet[/10.142.4.104:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 28121,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Any idea what might be the problem ?

Thanks,
Dusan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3812e7cf-2ee7-4224-8a7d-d87d4c92e6f8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #2

I'm curious, I noticed you have https, and then http in your above
examples. Is that a typo (the https) or is that intentional?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2547aad6-8912-4b07-a64e-b0d38f602eb8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Dušan Đorđević) #3

Intentional. HTTPS goes to web server, http requests goes to
elasticsearch, port 9200

On Mon, Mar 24, 2014 at 3:34 PM, Binh Ly binhly_es@yahoo.com wrote:

I'm curious, I noticed you have https, and then http in your above examples.
Is that a typo (the https) or is that intentional?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/7hPvjKpFcmQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2547aad6-8912-4b07-a64e-b0d38f602eb8%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Dušan Đorđević

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALwtfptQby3evj9A35rwg9P6tjBGM-Zg2ZfyVMYuFNnFvS8T-g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #4

Another q, did you open up the config.js file in the Kibana install, and
change the elasticsearch url to explicity point to the "http" address of
your ES instance?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/504f05db-e2b5-4a7e-98a8-bc7d06e3f61a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Dušan Đorđević) #5

On Mon, Mar 24, 2014 at 3:49 PM, Binh Ly binhly_es@yahoo.com wrote:

Another q, did you open up the config.js file in the Kibana install, and
change the elasticsearch url to explicity point to the "http" address of
your ES instance?

Yes, I assume that is how Kibana knows where is Elasticsearch, config file says:

elasticsearch: "http://10.142.4.104:9200",

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALwtfpu5mH-cX%3D_2xrk-iDDjRsiU9huDgN8U791M6cvZi4bXvg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Harry Waye-2) #6

Is it likely that you have a cross domain issue here?

On Monday, March 24, 2014 3:59:35 PM UTC, Dušan Đorđević wrote:

On Mon, Mar 24, 2014 at 3:49 PM, Binh Ly <binh...@yahoo.com <javascript:>>
wrote:

Another q, did you open up the config.js file in the Kibana install, and
change the elasticsearch url to explicity point to the "http" address of
your ES instance?

Yes, I assume that is how Kibana knows where is Elasticsearch, config file
says:

elasticsearch: "http://10.142.4.104:9200",

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3369b832-48db-442d-902d-c74e70c4d0a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Dušan Đorđević) #7

Maybe it is a cross domain, but I do not have idea what might be wrong...

On Tue, Mar 25, 2014 at 1:06 AM, Harry Waye harry@arachnys.com wrote:

Is it likely that you have a cross domain issue here?

On Monday, March 24, 2014 3:59:35 PM UTC, Dušan Đorđević wrote:

On Mon, Mar 24, 2014 at 3:49 PM, Binh Ly binh...@yahoo.com wrote:

Another q, did you open up the config.js file in the Kibana install, and
change the elasticsearch url to explicity point to the "http" address of
your ES instance?

Yes, I assume that is how Kibana knows where is Elasticsearch, config file
says:

elasticsearch: "http://10.142.4.104:9200",

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/7hPvjKpFcmQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3369b832-48db-442d-902d-c74e70c4d0a0%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Dušan Đorđević

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALwtfpu-Mmdw5WBDDmMzo96YjbH5UuBXeOYZU36_2wjCZ_sRuA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Nish) #8

Have you figured out a solution ?
I am getting this all of a sudden !
I can access it ok via ip address but not via kibana via nginx rev proxy ..

On Monday, March 24, 2014 9:48:21 AM UTC-4, Dušan Đorđević wrote:

Hi,

I downloaded elasticsearch-1.0.1.noarch.rpm,
logstash-1.4.0-1_c82dc09.noarch.rpm and kibana-3.0.0.tar.gz from
http://www.elasticsearch.org/overview/elkdownloads/ and installed them on
RHEL 6 with Apache and self signed http cert.

I replaced default Kibana dashboard with logstash dashboard that comes
with Kibana (cp logstash.json default.json in kibana/app/dashboards)

When I connect from another machine's browser to
https://10.142.4.104/kibana I get following error message:

Could not reach http://10.142.4.104:9200/_nodes. If you are using a
proxy, ensure it is configured correctly

However from that same machine curl http://10.142.4.104:9200/_nodes works
without any problems, and one with pretty output also:

curl 10.142.4.104:9200/_nodes/process?pretty
{
"cluster_name" : "aerlingus",
"nodes" : {
"avemXrb9SB6lxgxgL54ecA" : {
"name" : "central-log-server",
"transport_address" : "inet[/10.142.4.104:9300]",
"host" : "central-log-server",
"ip" : "10.142.4.104",
"version" : "1.0.1",
"build" : "5c03844",
"http_address" : "inet[/10.142.4.104:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 28121,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Any idea what might be the problem ?

Thanks,
Dusan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78e8b516-dad7-4ede-9cb1-c2970c250d51%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #9

You can find an example reverse proxy config for nginx here -
https://github.com/elasticsearch/kibana/blob/master/sample/nginx.conf

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 May 2014 11:34, Nish electronish@gmail.com wrote:

Have you figured out a solution ?
I am getting this all of a sudden !
I can access it ok via ip address but not via kibana via nginx rev proxy
..

On Monday, March 24, 2014 9:48:21 AM UTC-4, Dušan Đorđević wrote:

Hi,

I downloaded elasticsearch-1.0.1.noarch.rpm, logstash-1.4.0-1_c82dc09.noarch.rpm
and kibana-3.0.0.tar.gz from
http://www.elasticsearch.org/overview/elkdownloads/ and installed them
on RHEL 6 with Apache and self signed http cert.

I replaced default Kibana dashboard with logstash dashboard that comes
with Kibana (cp logstash.json default.json in kibana/app/dashboards)

When I connect from another machine's browser to
https://10.142.4.104/kibana I get following error message:

Could not reach http://10.142.4.104:9200/_nodes. If you are using a
proxy, ensure it is configured correctly

However from that same machine curl http://10.142.4.104:9200/_nodesworks without any problems, and one with pretty output also:

curl 10.142.4.104:9200/_nodes/process?pretty
{
"cluster_name" : "aerlingus",
"nodes" : {
"avemXrb9SB6lxgxgL54ecA" : {
"name" : "central-log-server",
"transport_address" : "inet[/10.142.4.104:9300]",
"host" : "central-log-server",
"ip" : "10.142.4.104",
"version" : "1.0.1",
"build" : "5c03844",
"http_address" : "inet[/10.142.4.104:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 28121,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Any idea what might be the problem ?

Thanks,
Dusan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/78e8b516-dad7-4ede-9cb1-c2970c250d51%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/78e8b516-dad7-4ede-9cb1-c2970c250d51%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624buhQgcYJ-_wT%2B%2BVK3agQuWfrSc2AYxQ3%2B1aN9UHV%3DMWQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Nish) #10

yeah ; I figured out ; actually somehow I deleted TCP:80 from my security
group (I guess lack of sleep made me a zombie )

On Mon, May 5, 2014 at 9:36 PM, Mark Walkom markw@campaignmonitor.comwrote:

You can find an example reverse proxy config for nginx here -
https://github.com/elasticsearch/kibana/blob/master/sample/nginx.conf

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 May 2014 11:34, Nish electronish@gmail.com wrote:

Have you figured out a solution ?
I am getting this all of a sudden !
I can access it ok via ip address but not via kibana via nginx rev proxy
..

On Monday, March 24, 2014 9:48:21 AM UTC-4, Dušan Đorđević wrote:

Hi,

I downloaded elasticsearch-1.0.1.noarch.rpm, logstash-1.4.0-1_c82dc09.noarch.rpm
and kibana-3.0.0.tar.gz from
http://www.elasticsearch.org/overview/elkdownloads/ and installed them
on RHEL 6 with Apache and self signed http cert.

I replaced default Kibana dashboard with logstash dashboard that comes
with Kibana (cp logstash.json default.json in kibana/app/dashboards)

When I connect from another machine's browser to
https://10.142.4.104/kibana I get following error message:

Could not reach http://10.142.4.104:9200/_nodes. If you are using a
proxy, ensure it is configured correctly

However from that same machine curl http://10.142.4.104:9200/_nodesworks without any problems, and one with pretty output also:

curl 10.142.4.104:9200/_nodes/process?pretty
{
"cluster_name" : "aerlingus",
"nodes" : {
"avemXrb9SB6lxgxgL54ecA" : {
"name" : "central-log-server",
"transport_address" : "inet[/10.142.4.104:9300]",
"host" : "central-log-server",
"ip" : "10.142.4.104",
"version" : "1.0.1",
"build" : "5c03844",
"http_address" : "inet[/10.142.4.104:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 28121,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Any idea what might be the problem ?

Thanks,
Dusan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/78e8b516-dad7-4ede-9cb1-c2970c250d51%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/78e8b516-dad7-4ede-9cb1-c2970c250d51%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624buhQgcYJ-_wT%2B%2BVK3agQuWfrSc2AYxQ3%2B1aN9UHV%3DMWQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAEM624buhQgcYJ-_wT%2B%2BVK3agQuWfrSc2AYxQ3%2B1aN9UHV%3DMWQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CANma5K7O0n6vrePxvW0fOh2%2BS0Dq2oQTvobkYW6y-r4o_s26zQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #11