Unable to drill into cluster in Marvel

monitoring

(Dan) #1

I have a fresh install of ES 2.0 with the latest versions of Kibana and Marvel. I am able to hit Kibana and navigate without issue. I am able to use the new (page switcher?) to switch from Kibana to Marvel and I see my overview cluster stats. However, when I attempt to click on the cluster in attempt to drill into the indices/nodes data, there is no action and I get the following error from Chrome dev tools:

Error: Could not locate that index-pattern (id: [.marvel-es-]YYYY.MM.DD)
    at applyESResp (marvel.bundle.js:41944)
    at wrappedCallback (commons.bundle.js:38613)
    at commons.bundle.js:38699
    at Scope.$eval (commons.bundle.js:39742)
    at Scope.$digest (commons.bundle.js:39554)
    at Scope.$apply (commons.bundle.js:39846)
    at done (commons.bundle.js:35381)
    at completeRequest (commons.bundle.js:35595)
    at XMLHttpRequest.xhr.onreadystatechange (commons.bundle.js:35534)

Here are my indices:

curl 'http://localhost:9200/_cat/indices?v'

health status index                 pri rep docs.count docs.deleted store.size pri.store.size 
green  open   .kibana                 1   1          3            0       47kb         21.3kb 
green  open   .marvel-es-data         1   1          1            0      7.1kb          3.5kb 
green  open   logstash-2015.11.05     5   1     868404            0    403.5mb          202mb 
green  open   .marvel-es-2015.11.06   1   1     108949          130     80.7mb         40.3mb 
green  open   logstash-2015.11.06     5   1   12950403            0       24gb           12gb 

Is there an index I need to create manually?

Please let me know if you need any additional information. Thanks.


(Chris Cowan) #2

It looks like your Kibana index pattern is missing, [.marvel-es-]YYYY.MM.DD. Normally this index pattern is created when the Kibana server is started. You can manually recreate this by going to the indices tab in the settings section in Kibana. Check "Use event times to create index names" checkbox, entry [.marvel-es-]YYYY.MM.DD into the field that contains logstash-*. Then choose timestamp as the "Time-Field Name"


(system) #3