Unable to find "kibana.autocompleteTimeout" in kibana.yml

I have a control visualization , where i can't seem to find a filename that was processed . i can only see one of the files (two log files were ingested) . These are very large files and contain huge lines of information

upon some google search , i found directions to increase kibana.autocompleteTimeout kibana.yml . However mine doesn't seem to have it , does it need to be added manually ?

root@dev-eng05:/etc/logstash/conf.d# grep -i time /etc/kibana/kibana.yml
# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500
# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
#elasticsearch.requestTimeout: 30000
# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000
# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

Hi @Shreesh_Narayanan,

yes, you can add this setting manually, and Kibana will respect it. The kibana.yml file that ships with Kibana doesn't include all available options, but anything documented here is valid for your kibana.yml file.

1 Like

@Larry_Gregory thank you !! :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.