Unable to load in new Kibana Plugin

Hi,

I am trying to load in a new plugin. I did the following steps:

  • bin/kibana-plugin install https://github.com/prelert/kibana-swimlane-vis/releases/download/v7.4.2/prelert_swimlane_vis-7.4.2.zip --allow-root
  • systemctl restart kibana

The output of the install is fine:

[root@host kibana]# bin/kibana-plugin install https://github.com/prelert/kibana-swimlane-vis/releases/download/v7.4.2/prelert_swimlane_vis-7.4.2.zip --allow-root
Attempting to transfer from https://github.com/prelert/kibana-swimlane-vis/releases/download/v7.4.2/prelert_swimlane_vis-7.4.2.zip
Transferring 196447 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Plugin installation complete

I don't see visualizations for swimlane. It seems the plugin doesn't load.
I'm doing everything as root, could permissions be a problem? I didn't find anything in de messages log.

Any suggestions?

Best regards,
Robin

Hello,

What is the message shown in the Kibana logs ? Can you please share that ? I haven't used this plugin , but found some documentation on it which may(?) be helpful .


May be check this issue as well: https://github.com/prelert/kibana-swimlane-vis/issues/58

cc @Peter_Harverson

Thanks
Rashmi

@Robin020 apologies for the delay in responding. A few users have reported permissions issues with installing 7.1, 7.2 and 7.3 versions of the swimlane plugin - see this issue. After installing, does the ownership of the kibana/plugin/prelert_swimlane_vis look ok?

When the Kibana restarts, do you see errors related to the swimlane plugin in the server console log?

For the 7.5.x swimlane plugin releases, I switched to using the @kbn/plugin-helpers package to build the plugin, where previously I was building the zip file manually. If upgrading to Kibana 7.5.x is an option, it would be interesting to see whether the same issue occurs, or if the swimlane appears correctly in the list of available options in KIbana Visualize.

Regards
Pete

Correct, it was a permissions issue which is now solved. Thanks

1 Like