Unable to manually specify start/end timestamps in date range selector

What am I doing wrong? I'm trying to manually adjust start/end timestamps in the date range selector in discover tab, but it just prints expected format in red and doesn't give me any way to apply manually entered timestamp?

kibana

Try the below format.

Still doesn't work.
image

Check your advanced settings and look for MMMM Do YYYY which is the format it is looking for. The format should be like MMM D, YYYY @ HH:mm:ss.SSS.

Or if you want to maintain the format that is in there here is a guide to what it means.

MMMM is January
Do is 1st
etc

So in your example above it would need to be October 8th 2020, 07:30:00.000 -0700. The last part is your timezone which I don't know what you would want to use.

That doesn't work either. In fact, any manual input into "Start date" field shows format message in red without any way to apply the changes. Even if i just erase a zero and then put it back it still shows the error.
image

I checked the date format in advanced settings and it is set to MMMM Do YYYY, HH:mm:ss.SSS zz so the format from screenshot above should work.

I set my settings to what you have for testing and the below works. I guess the zz doesn't matter.

July 12th 2014, 09:19:26.823

I must've tried 40 different formats by now including Unix time. Nothing works.
Running Kibana 7.6.2 btw. Was something fixed in a newer version if that's what you're using?

None of the following works:
October 8th 2020, 07:30:00.000 PDT
October 8th 2020, 07:30:00.000
October 8th 2020, 07:30:00
October 8th 2020, 07:30:00.000 -0700
10/8/2020 07:30:00
1602190130
1602215325000

On discovery do you have a timeline? Click and drag to select a portion of the timeline and it will fill in your date ranges with acceptable ranges. You aren't using the default settings either. Might return settings to default and try again.

Resetting to default finally worked. Is this a bug that timestamp format cannot be customized?