Unable to set discovery.zen.minimum_master_nodes from kibana?


(Yu Watanabe) #1

Hi!

I would like to ask question regarding to dyanamic setting in elasticsearch using cluster-update-api.

Environment
elasticsearch ver 5.0.0 alpha4-1
kibana ver 5.0.0 alpha4-1

Total of 4 nodes. (3 regular nodes and 1 client node)

[root@kibana ec2-user]# curl -XGET http://localhost:9200/_cat/health?v
epoch      timestamp cluster status node.total node.data shards pri relo init unassign pending_tasks max_task_wait_time active_shards_percent
1469173492 16:44:52  elastic green           4         3    237 118    2    0        0             0                  -                100.0%

[root@kibana ec2-user]# curl -XGET http://localhost:9200/_cat/nodes?v
ip           heap.percent ram.percent cpu load_1m load_5m load_15m node.role master name
172.30.1.31             4          66  12    0.54    0.21     0.11 mdi       -      node-3
172.30.1.157            2          90   0    0.03    0.04     0.05 i         -      client-1
172.30.1.46             3          76   7    0.04    0.04     0.05 mdi       -      node-2
172.30.1.196            4          80   0    0.06    0.05     0.05 mdi       *      node-1

Problem
discovery.zen.minimum_master_nodes is unable to update from kibana interface.

However, it works perfectly from the command line.
Below is command executed from the client node

[root@kibana ec2-user]# curl -XPUT http://localhost:9200/_cluster/settings -d '{ "transient" : { "discovery.zen.minimum_master_nodes": 2 }}'
{"acknowledged":true,"persistent":{},"transient":{"discovery":{"zen":{"minimum_master_nodes":"2"}}}}[root@kibana ec2-user]#

Question
Is this a problem? Or is it what it is?

Thanks,
Yu Watanabe


(Jared Carey) #2

You cropped off the connection URL for Kibana in your screenshot. What is the URL that you are sending the request to? What is the exact error that you are getting?


(Yu Watanabe) #3

Sorry for lack of information.
The error I get is red cross on the left hand side and below error.

Expected one of GET/POST/PUT/DELETE/HEAD
Syntax error

I had no error logs in my client, master , data nodes.


(Jared Carey) #4

Ah. Just move the opening curly brace to a new line rather than having it on the request line.

PUT /_cluster/settings
{
  "transient" : {
    "discovery.zen.minimum_master_nodes" : 2
  }
}

(Yu Watanabe) #5

@jpcarey

Oh !

Thanks!


(system) #6