Unable to use Kibana plugin for 6.3


I'm beginning with ELK so please be gentle. I just developed what looked like a sample plugin for adding a visualization to Kibana, because I need to have a particular design for my purpose. So I created my plugin under /kibana/plugins. It contains public/vis.js, public/vis_controller.js, public/options_template.html, index.js and package.json (omitting the .less). I've already done some research about what could have possibly broken my build, but I can't find what. In fact, even Kibana's documentation could not help me. Tutorials on Google are outdated, I specifically need a 6.3 working plugin.

I already tried to use the plugin-generator, but the output sample plugin is not working.
The ./bin/kibana-plugin install my_vis_plugin.zip does not work, telling me it doesn't recognize any plugin in the archive.
And for the basic method, i.e simple running Kibana, 1st : it takes forever (330s), and 2nd : it breaks at the end, telling me with over 200 error lines It does not find my plugin, the main error being it does not find the plugin in /optimize/bundles (what I suppose will work if the plugin is located correctly).

I already tried to move my plugin inside the core-plugins folder (out of curiosity) but it rejected me even harder, telling me the dependencies were broken.

I also tried to modify the route in index.js by putting the 'real' one : /plugins/my_plugin_vis/public/vis
instead of this one :
none of them worked.

Whatever the documentation or tutorial I could find was none of a help for me.
I would be grateful if someone could tell me what is actually happening so my setup, and how to fix it.

V. Courtois

PS : Please note that I am currently working with "Restricted Diffusion" data.

What plugin generator did you use for Kibana?
From 6.3 there is an embedded one in the Kibana repo that you can use to generate:

There are some more guides in there.

Well, yeah. That's the one directly in the kibana setup I used.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.